Thread: Over heating
View Single Post
  #1 (permalink)  
Old 10 Jun 2009, 02:37 pm
Cowboyfann Cowboyfann is offline
Fresh Cruiser
 
Join Date: Jun 2009
Posts: 4
Default Over heating

02 non turbo PT Cruiser. Had leaking coolant bypass tubes replaced. Car ran fine and cool under all conditions. When I got car back it overheated going up a steep grade with AC on but would cool down by turning AC off. No problems with AC on or off except going up grade. Rad. flushed twice, new rad cap., new high and low relys, fuses good, new fan (old fan did not work on low speed), new thermostat and sensor. Dealer now says that AC condenser is blocked and is causing heat to go through radiator which is causing it to run hot and high pressure line at 400 psi. Dealer wants to change condenser for $600 but will not guarantee problem will be fixed. Noticed they used green coolant and I tried to find red Chrysler coolant to replace it but could not find it. Used orange all purpose coolant. can this be the problem? Under a load is the compressor supposed to shut off and if so how can I check for that? Any suggestions? I am out of patience and ideas Thanks
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243