View Single Post
  #5 (permalink)  
Old 23 Mar 2010, 07:54 pm
Dino's Avatar
Dino Dino is offline
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,839
Default Re: Overheating Driving me nuts

Quote:
Originally Posted by sandyltn12 View Post
I have a 2006 Cruiser. Last summer the fan fuse kept popping and it was overheating. If I changed out the fuse it would work great for a while. It now is overheating and the fuse is just fine.
It mostly happens stuff in traffic, idling. What I find very odd is that if I pop it into neutral the temp goes back down. I know enough about cars to get me in trouble and my local dealership has complete idiots for employees.

I have had so many problems with the front end, I wonder if this can be related somehow.

Any ideas?? Thanks

The fan is a known issue mine was replaced at 39000. Make sure it's even working on it's high speed, turn the AC on and take a look. You should hear it kick on when your at a light also when the car hits a certain temperature while sitting at the light.

Last edited by Dino; 29 Mar 2010 at 12:25 pm.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243