View Single Post
  #1 (permalink)  
Old 30 Apr 2011, 04:39 pm
worcestersauced worcestersauced is offline
Fresh Cruiser
 
Join Date: Apr 2011
Posts: 10
Default Timing belt installation check from the top?

I've got a problem with a 2004 PT Cruiser automatic nonturbo.

Short Story: PT running rough. Mechanic might have installed timing belt wrong. Can someone tell me how to check the timing belt from the top to confirm this?

Long story:
I created another thread because I had a P0508 code related to IAC motor. I troubleshooted that and I'm pretty sure that there is nothing wrong with that system. The car is been runnig rough since I picked up from the mechanic who did the timing belt at 90k miles. So I'm starting to think that the rough idle is due to the timing belt being off a tooth or two. From the forums, I see that it's hard to get the timing right.

I want to check the timing belt installation. This post mentions disassembly from top just enough to check the timing belt installation. Can somebody describe to me how I would do this? I want to go back to my mechanic so he can make it right, but considering the fact that he'd have to redo the whole job, he might be reluctant so I want to be armed with this knowledge when I go back and talk to him.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99