View Single Post
  #6 (permalink)  
Old 11 Mar 2014, 04:38 pm
quicksilverdon's Avatar
quicksilverdon quicksilverdon is offline
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: REAR WHEEL BEARING??

Quote:
Originally Posted by njsteve1 View Post
I had a similar issue with my 03. I had a clucking/clicking sound every time I used the brakes. Drove me nuts. Check all the rear suspension could not find anything. What I finally found was the inner brake pad had came loose from the attach spring mounting clip. The inner brake pad was rattling around against the metal hardware.
I had that happen also, BUT:
1) He says it only clicks when hit hits the brakes, with the pad problem, the clicking would go away when I hit the brakes...
2) He mentions an auto adjuster, which implies rear drums...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47