View Single Post
  #8 (permalink)  
Old 18 May 2017, 02:14 am
AngryPTOwner AngryPTOwner is offline
Fresh Cruiser
 
Join Date: Jul 2011
Posts: 34
Default Re: 2006 PT Overheating issues

Quote:
Originally Posted by rsrocket1 View Post
Never mind.
I wanted to welcome you and encourage you to introduce yourself since you don't show anything on your profile. Then I looked up your previous posts.

Looks like every time you start a thread you are about to give up on this car

Did you ever get your camshaft sensor problem fixed from 2011?
You never replied whether or not the help given here fixed it I lost those threads LONG ago. Camshaft sensor has been replaced yearly since 2011 WITH the crankshaft sensor. Mopar , dealer parts, or something from Autozone they keep failing

Did you ever get your grinding noise problem fixed from 2012?
You never replied whether or not the help given here fixed it Grinding noise was the idiots at Midas messing up a caliper when they rotated my tire. The replaced everything

Did you ever get you headlight problem fixed from 2013?
You never replied whether or not the help given here fixed it. Nothing fixed the headlights. They are still non functional. Dealer tired a new TIPM, flashed it , they didn't turn on. They said "It'll probably be another $1200 to take the dash apart and find whatever electrical problem is causing all this." I declined and I just drive around with brights on.

Did you ever get your crankshaft sensor problem fixed from 2015?
You never replied whether or not the help given here fixed it Crankshaft had to be replaced yearly along with Camshaft.
This car has quite literally been the worst car I've ever owned. It's always in need of something repaired every 3-5 months like clockwork.. I got it in 2007, one week after I got it, my drivers side window fell in the door. The dealer said it was "Defective" and replaced the door.

2008 Less than a year of having it, front drivers side tie rod broke.
2009 First camshaft / crankshaft sensor replaced
2009 Back windshield wiper won't turn on
2010 Front windshield wipers won't turn off
2010 two lugnuts just "fell off"
2010 First battery dies
2011-2017 some of the problems listed above not to mention replaced every sensor on the car, AC problems, Back windshield wiper is dead again, exhaust had to be replaced completely and i can't open the passenger side door from the inside.

This car is extremely unreliable. I'm not one of those people who doesn't get it serviced ether. I always get it routinely looked at.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243