View Single Post
  #6 (permalink)  
Old 20 Sep 2017, 08:54 pm
Vengence's Avatar
Vengence Vengence is offline
Cool Cruiser
 
Join Date: Mar 2009
Location: Buffalo, NY
Posts: 341
Default Re: Thumping in front end over bumps

I just had this issue not even 3 weeks ago. And after having the Struts, CV Shafts, Sway Bar and Links, and mounts replaced, My new mechanic and I found the issue. For me it was the Control Arm and Ball Joint. Ball joint was minor but the Bushings on my Control Arm was completely shot and that was the source of my thumping and bumping sounds and feelings. Now the passenger side is doing it ever so slightly so that is being replaced tomorrow when I get home from work. FYI, if this is your issue as well, be sure to get the Control Arm and Ball joint as one piece and not separately. Someone on this forum mentioned RockAuto I believe? Or something?


Also, Reffering to above mentioned comments...... I was also advised to check sway bar links/remove them for testing purposes and where that is a great idea, I did not have to do so because upon putting it on the lift to do that, we noticed the shot bushing and replaced the control arm. After that......Perfection. At least on the drivers side.
__________________
2008 PT Cruiser LX Inferno Red

Last edited by Vengence; 20 Sep 2017 at 08:57 pm.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99