View Single Post
  #4 (permalink)  
Old 10 Nov 2017, 12:03 pm
Handy_Cruiser's Avatar
Handy_Cruiser Handy_Cruiser is offline
Obsessed Cruiser
 
Join Date: Oct 2013
Location: Arkansas
Posts: 9,586
Default Re: new thermostat but still no heat from heater any ideas

If the issue is just no heat from the heater but the gauge needle is reading about right in the middle when the engine is warm:

1. First make sure the air is bled out of the cooling system as Steve recommended.

2. ]If all is good, It may be a problem with the blend door or the controls. [EDITED] Go here for directions on how to check this.

new thermostat but still no heat from heater any ideas

If not working correctly, you will need the service manual for further diagnostics. Here's a copy if you don't have one:

https://drive.google.com/file/d/0B9C...ew?usp=sharing

3. If this is not the problem, you may have a clogged heater core. To service this, you will need to take both heat hoses loose and back flush the heater core assuring good flow.

Of course, the issue could be other problems as well. But I believe these are the most likely based on what you have said.
__________________

Last edited by Handy_Cruiser; 10 Nov 2017 at 07:31 pm.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99