View Single Post
  #4 (permalink)  
Old 26 Nov 2017, 07:43 pm
rckstein's Avatar
rckstein rckstein is offline
Banned
 
Join Date: Dec 2010
Location: Texas
Posts: 15,518
Default Re: 2007 pt cruiser engine needs to start twice

Quote:
Originally Posted by TDFF View Post
My 2007 pt cruiser has a weird problem. When the engine is cold (overnight), the engine will crank but won't start in the first try. It will start in the second try. However, when engine is hot, it starts fine. Also, the check engine light is not on. The problem starts this Oct. when temperature starts to be low in the morning (32F). But because the car start eventually, the battery should be OK, right?

The engine cranks and it will start eventually, so the starter should be fine, right?

I tried to turn the key to ON without starting the engine and waited for a few seconds, the engine still could not start in the first try but will start in the second try. So I think the fuel pump and fuel filter should be fine, too.

I did an oil change this Sep. and the car past the NY state annual inspection this Oct.

So what do you think is wrong?

I'd like to take the car to a mechanics for an inspection. However, it seems that it is really hard to repeat the problem right away, and I don't want to leave the car there for a few days. I appreciate it very much, if anyone could point me to a possible cause.

Thank you very much.
Welcome to the forum

Your PT sounds like it has the same problems as mine when the fuel pump was going out. After sitting overnight, it would have a long crank on a cold engine. But after starting and repeatedly shutting down and restarting numerous times throughout the day, it would run fine. Then hard to start again the next morning.

There is no fuel filter and you can have a fuel system pressure test done. Which I did have and the fuel pump was supplying enough pressure and the fuel injectors were not leaking down. Apparently there is a check valve in the fuel pump that was not holding the system pressure overnight but slowly leaking down. Had the fuel pump replaced 08/14 and has fired up within a few seconds ever since.

When you get a chance please go to Welcome New PT Cruiser Members - PT Cruiser Forum and create an intro thread.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243