View Single Post
  #1 (permalink)  
Old 14 Feb 2005, 09:34 pm
jmack jmack is offline
Cool Cruiser
 
Join Date: Jun 2004
Location: blaine, tn, USA.
Posts: 233
Send a message via AIM to jmack
Default MultiFunction Switch Issues-HELP !!!

I have read the previous post and I am utterly confused. I am still having an issue with my headlights. Today after work, my low beams wouldn't come on. I had to drive home on bright about halfway home, then they worked again. It is an ittermittent problem. All of my buddies here have suggested to replace the multifunction switch. Now here is my question?:

I removed the column cover and I tried to locate the multifunction switchand I don't think I want to remove that. Can someone please help me??. Needless to say, I am totally confused. Where is this part exactly? Can someone tell me geographically where this part is?(update, I know now the whole stalk is replaced) Is this switch like the entire two stalks and everything? Is that what comes off? The only torx screws I saw looked like they held the steering wheel on the column. Can someone please help? This is a big safety issue as I don't see how I can drive home from work with no headlights at night.
Reply With Quote
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99