PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Regional Forums > Europe PT Forum

PT Cruiser Forum

Advertisements
Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04 Apr 2013, 04:25 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 8
Default Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

So.. here we are..

I currently have some issues with a PT Cruiser '04 2.2 CRD

  • It didn't want to start good
  • Then it didnt start at all
  • When we give it a pull and put in gear runs fine
  • Changed battery from my own car
  • Started fine
  • Bought new battery, same specs as mine (72ah / 680a cold start)
  • Doesn't want to start again
  • Linked another battery to the new one with cables
  • Still doesnt want to start.....
  • Gave it a pull again, runs fine...

Now.. we were pretty sure that the battery was the problem.. untill now !?

Anyone got any clues ? Could it be the starter that doesn't go around fast enough or...?

One thing that might be of value is that the 4th injector at the end of the rail shows a very small leak. This was however the case for a few months already and this wasn't a problem when starting with my battery ?

I really don't have a clue what could be the problem right now ?

Any advice much appreciated !
PoloB12
Reply With Quote
  #2 (permalink)  
Old 04 Apr 2013, 06:23 am
ROCKETMAN8060's Avatar
Senior Cruiser
 
Join Date: Jan 2010
Location: Orlando FL
Posts: 1,753
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

Did you check the coil?
__________________
ROCKETMAN8060
Reply With Quote
  #3 (permalink)  
Old 04 Apr 2013, 06:45 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 8
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

Quote:
Originally Posted by ROCKETMAN8060 View Post
Did you check the coil?
Thank you for your response, but could you explicate a little more ?

I don't understand what u mean... Language issue as well since I am Dutch.

Thanks

( BTW ITS A DIESEL, SHOULD THE COIL REFER TO IGNITION COIL )

Last edited by PoloB12; 04 Apr 2013 at 06:47 am. Reason: Extra info added
Reply With Quote
  #4 (permalink)  
Old 04 Apr 2013, 11:23 am
Crid's Avatar
Regular Cruiser
 
Join Date: Feb 2012
Location: Ontario,Canada
Posts: 146
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

Quote:
Originally Posted by PoloB12 View Post
Thank you for your response, but could you explicate a little more ?

I don't understand what u mean... Language issue as well since I am Dutch.

Thanks

( BTW ITS A DIESEL, SHOULD THE COIL REFER TO IGNITION COIL )
Yes check the ignition coil.
__________________
2006 Cruiser, Non-Turbo, 19 inch Konig Trouble rims on 225/35/19 Ironman Imove tires, Airaid CAI, E3 Plugs, msd super conductor 8.5 mm wires, Freedon Design Strut Tower Brace, Glow Shift Pillar gauges, EBC Slotted Rotors with EBC Green Stuff Ceramic Fiber Core Pads, Lowerd on Tien springs, Full Custom Kenwood Excelon sound system with 1 12" JL Audio W0, 8000k Blue hids up top and aftermarket OEM Fogs with white 8000k in bumper. Ipcw Bermuda black true led taillights with tinted reverse lights.
Reply With Quote
  #5 (permalink)  
Old 04 Apr 2013, 11:29 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 8
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

Sorry guys, but a diesel engine doesn't have an ignition coil as far as I know ?

We did change the glow plugs if that's what you are referring to ?

Thanks
Reply With Quote
  #6 (permalink)  
Old 04 Apr 2013, 11:34 am
Crid's Avatar
Regular Cruiser
 
Join Date: Feb 2012
Location: Ontario,Canada
Posts: 146
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

Quote:
Originally Posted by PoloB12 View Post
Sorry guys, but a diesel engine doesn't have an ignition coil as far as I know ?

We did change the glow plugs if that's what you are referring to ?

Thanks
No I did mean the coil didnt realize it was deisel. Hmm I'm stumped may have to wait for some one else to chime in good luck tho. Lots or smart ppl on here
__________________
2006 Cruiser, Non-Turbo, 19 inch Konig Trouble rims on 225/35/19 Ironman Imove tires, Airaid CAI, E3 Plugs, msd super conductor 8.5 mm wires, Freedon Design Strut Tower Brace, Glow Shift Pillar gauges, EBC Slotted Rotors with EBC Green Stuff Ceramic Fiber Core Pads, Lowerd on Tien springs, Full Custom Kenwood Excelon sound system with 1 12" JL Audio W0, 8000k Blue hids up top and aftermarket OEM Fogs with white 8000k in bumper. Ipcw Bermuda black true led taillights with tinted reverse lights.
Reply With Quote
  #7 (permalink)  
Old 04 Apr 2013, 11:43 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 8
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

Quote:
Originally Posted by Crid View Post
No I did mean the coil didnt realize it was deisel. Hmm I'm stumped may have to wait for some one else to chime in good luck tho. Lots or smart ppl on here
Just realised now that I am on an American forum where diesel engines are not common at all, maybe not even sold at all..

Someone has been so kind to move this topic to the correct section on this forum.

Thanks
Reply With Quote
  #8 (permalink)  
Old 04 Apr 2013, 12:07 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

you r right no desiel PT s here there were a small number of the Jeep Libertys sold with the desiel but no pts i am told we can not even import them
Reply With Quote
  #9 (permalink)  
Old 04 Apr 2013, 04:02 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

To summarize, seems it starts with getting wheels turning and putting in gear, but not with starter....
If I have that right, check the cables going to the sarter - it isn't your starter itself, since it turns, but I suspect you have high resistance due to corrosion.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #10 (permalink)  
Old 05 Apr 2013, 06:18 am
Fresh Cruiser
 
Join Date: Apr 2013
Posts: 8
Default Re: Start problems 2.2 CRD 122hp - Battery replacement doesn't seem to have effect

Quote:
Originally Posted by quicksilverdon View Post
To summarize, seems it starts with getting wheels turning and putting in gear, but not with starter....
If I have that right, check the cables going to the sarter - it isn't your starter itself, since it turns, but I suspect you have high resistance due to corrosion.
Thanks for your reply, is there some easy way to check the resistance of the starter ?

How would you explain the fact that with the battery from my car it does start ? And an brand new with same specs does not work ?

Thanks
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BATTERY REPLACEMENT? WAGGGG General PT Cruiser Discussions 1 04 Jul 2012 02:44 pm
2003 Touring doesn't start TimothyG Tech & Performance Forum 3 11 Jan 2011 07:36 am
2001 PT Cruiser Doesn't Start Properly cusunfireguy Tech & Performance Forum 5 22 Jun 2010 05:39 pm


All times are GMT -5. The time now is 10:24 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors