PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Regional Forums > Europe PT Forum

PT Cruiser Forum

Advertisements
2.2 CRD Glow Plugs not getting power

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03 Feb 2015, 03:20 pm
Fresh Cruiser
 
Join Date: Feb 2015
Location: UK
Posts: 9
Default 2.2 CRD Glow Plugs not getting power

Since I got my 2.2 CRD cruiser it has had issues starting in the cold. I thought this might be the turbo pipe (as car went into limp mode when driving on a motorway) so I recently replaced that (the old one had a bit of rubber glued on!) but it didn't solve the problem.

The mechanic tested the glow plugs when I was starting up the car and he said they aren't getting any power.

I've tried changing over the glow plug relay in the pdc under the bonnet and it didn't solve the problem. Anyone know where I can get new relays from in the uk?

Is there anything else that it could be (like a engine temperature sensor or something like that?)

Last edited by adamg; 03 Feb 2015 at 04:28 pm.
Reply With Quote
  #2 (permalink)  
Old 03 Feb 2015, 03:48 pm
Fresh Cruiser
 
Join Date: Feb 2015
Location: UK
Posts: 9
Default Re: 2.2 CRD Glow Plugs not getting power

Forgot to mention glow plugs are new (old ones were the same) and it starts fine when it's warm (eg not freezing) outside or after it has been driven for a while.

Last edited by adamg; 03 Feb 2015 at 03:51 pm.
Reply With Quote
  #3 (permalink)  
Old 03 Feb 2015, 04:02 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: 2.2 CRD Glow Plugs not getting power

Please learn to reduce the size of your pictures on the forum.
Reply With Quote
  #4 (permalink)  
Old 03 Feb 2015, 04:51 pm
Fresh Cruiser
 
Join Date: Feb 2015
Location: UK
Posts: 9
Default Re: 2.2 CRD Glow Plugs not getting power

just took them off, too big
Reply With Quote
  #5 (permalink)  
Old 03 Feb 2015, 06:26 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,059
Default Re: 2.2 CRD Glow Plugs not getting power

There is a fusible link in the power circuit from the battery to the glow plugs through the relay.
Fuse #13 in the PDC protects the relay coil circuit; the PDC grounds the relay.

The diesel Fuel/Ignition System schematics take 15 pages, 35-50.
quicksilverdon and JoeX like this.

Last edited by sanatanadharma; 09 Nov 2016 at 09:58 am.
Reply With Quote
  #6 (permalink)  
Old 04 Feb 2015, 05:15 am
Fresh Cruiser
 
Join Date: Feb 2015
Location: UK
Posts: 9
Default Re: 2.2 CRD Glow Plugs not getting power

thanks will take a look in the pdc to see if I can spot it.
Reply With Quote
  #7 (permalink)  
Old 04 Feb 2015, 03:47 pm
Fresh Cruiser
 
Join Date: Feb 2015
Location: UK
Posts: 9
Default Re: 2.2 CRD Glow Plugs not getting power

I changed fuse 13 (see pic for anyone viewing) but its still not working.
My mechanic retested and said that no live is coming through to the relay when the key is turned.
Is there any other fuses that this could be or anything else?

Reply With Quote
  #8 (permalink)  
Old 04 Feb 2015, 04:23 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: 2.2 CRD Glow Plugs not getting power

from above post

There is a fusible link in the power circuit from the battery to the glow plugs through the relay.
Fuse #13 in the PDC protects the relay coil circuit; the PDC grounds the relay.


check the fuseable link not the fuse
Reply With Quote
  #9 (permalink)  
Old 04 Feb 2015, 06:18 pm
Fresh Cruiser
 
Join Date: Feb 2015
Location: UK
Posts: 9
Default Re: 2.2 CRD Glow Plugs not getting power

Ah right that makes sense. I'm not very good at wiring at all. As a rough guide whereabouts on the car Is the power circuit fuseable link be located? Under the seat? Or in the door/ under the main dash? It looks like this might be a job for a autoelectrician but he said he had never worked on a cruiser before and said he couldn't get parts!

Last edited by adamg; 04 Feb 2015 at 06:21 pm.
Reply With Quote
  #10 (permalink)  
Old 04 Feb 2015, 08:06 pm
Veteran Cruiser
 
Join Date: Sep 2010
Location: Walking distance to the embassy
Posts: 3,059
Default Re: 2.2 CRD Glow Plugs not getting power

Quote:
Originally Posted by adamg View Post
...whereabouts on the car Is the power circuit fuseable link be located? ...
The fusible link will be hidden under the tape-wrapped harness bundle that exits the PDC and runs rearward toward the firewall. A thick (6 gauge) black/ grey wire changes to a red wire after the fusible link. The wire goes to a connector near the firewall (left side, black, 4-pin, 3-wires). The fusible link and a splice should be near the connector.
1 -empty
2 -14 RD/DB
3 -10 RD
4 -10 RD/LB
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
NGK Plugs: V or G Power pmcruiser Tech & Performance Forum 5 11 Sep 2013 08:47 pm
misses bad, no power on hills and oil on plugs ashtrae311 Tech & Performance Forum 7 24 Dec 2011 03:33 am
Random power loss, glow plug light??? toooldforthis General PT Cruiser Discussions 30 27 Mar 2011 11:11 am
E# spark plugs + K&N filter = noticable power increase storemike Tech & Performance Forum 9 07 Dec 2009 09:06 pm
Random power loss, glow plug light???? toooldforthis Tech & Performance Forum 2 14 Nov 2008 02:11 pm


All times are GMT -5. The time now is 06:29 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors