PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Regional Forums > Europe PT Forum

PT Cruiser Forum

Advertisements
Couple of issues...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 13 Jun 2015, 08:20 am
Fresh Cruiser
 
Join Date: Jun 2015
Posts: 5
Default Couple of issues...

I bought my first PT Cruiser (2001 Limited Edition, 135000 miles) last week for 200, I had to spend another 200 on getting a new Power Steering Pipe installed as the original was leaking... now I have a weird, loud, squealing noise from the engine when I drive.
Also the car only came with one key and no remote, when I use the key in the drivers door it only opens the drivers lock, it makes the sound like it's trying the other locks, but nothing happens, any ideas what this could be?
The lock button on the drivers door still works and locks/unlocks all the doors.
Reply With Quote
  #2 (permalink)  
Old 13 Jun 2015, 09:00 am
Senior Cruiser
 
Join Date: Jan 2014
Location: SW PA
Posts: 1,336
Default Re: Couple of issues...

Quote:
Originally Posted by ZombieRodeo View Post
I bought my first PT Cruiser (2001 Limited Edition, 135000 miles) last week for 200, I had to spend another 200 on getting a new Power Steering Pipe installed as the original was leaking... now I have a weird, loud, squealing noise from the engine when I drive.
Also the car only came with one key and no remote, when I use the key in the drivers door it only opens the drivers lock, it makes the sound like it's trying the other locks, but nothing happens, any ideas what this could be?
The lock button on the drivers door still works and locks/unlocks all the doors.
If the loud squealing wasn't there before you had the new PS hose installed it could be the wrong fluid or just low
__________________
Addicted to Mopar You can tell how old I am..
65 Dodge Coronet 6 cyl 2dr Post
66 Ply Satellite with 273 engine swap to 69 340 4spd
70 340 4spd Dart Swinger "Those were the days my friend"
73 Charger SE
Had a few Vetts on the way 69, 85
Several Neons some flips
01 Sebring flip
Cruiser's 01, 220K Gone to a new home
Cruiser 03 133K Gone to a new home
Cruiser 06 110K Project Gone to new Home
Cruiser 05 Ltd 120,809 bought with broken belt Oct2015
May 16 Resurrected to once again roam the streets.

20 Miles South Of Pittsburgh
Reply With Quote
  #3 (permalink)  
Old 14 Jun 2015, 08:16 am
Fresh Cruiser
 
Join Date: Jun 2015
Posts: 5
Default Re: Couple of issues...

Thanks for the info, the power steering fluid is full, so I'll check with the garage to see what they put in... I did notice drive belt is a little worn so I don't know if that's the problem.

Regarding the locks, I only have one key and today it took me 18 attempts to open the door as when I unlock the car and release the key the lock just drops down again.
Yet the lock button on the drivers door locks and unlocks all the doors with no problems... Any ideas?
Reply With Quote
  #4 (permalink)  
Old 14 Jun 2015, 12:40 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: Couple of issues...

Quote:
Originally Posted by ZombieRodeo View Post
Thanks for the info, the power steering fluid is full, so I'll check with the garage to see what they put in... I did notice drive belt is a little worn so I don't know if that's the problem.

Regarding the locks, I only have one key and today it took me 18 attempts to open the door as when I unlock the car and release the key the lock just drops down again.
Yet the lock button on the drivers door locks and unlocks all the doors with no problems... Any ideas?
Are you talking about the passenger side door?
Reply With Quote
  #5 (permalink)  
Old 14 Jun 2015, 03:16 pm
Fresh Cruiser
 
Join Date: Jun 2015
Posts: 5
Default Re: Couple of issues...

Nope, the drivers side, none of the other locks work unless I use the button on the drivers door.

When I turn the key in the drivers side door, the lock pops up then goes back down again, the other locks make a sound like they're trying to move but don't.
I have to keep trying and usually after 10 or so attempts it will stay up and allow me to open the door.
Reply With Quote
  #6 (permalink)  
Old 14 Jun 2015, 04:21 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: Couple of issues...

I would suggest checking the 20 amp RKE fuse in the fuse box. Make sure you take the fuse out and clean the contacts.

Last edited by ptcruisersteve; 14 Jun 2015 at 04:34 pm.
Reply With Quote
  #7 (permalink)  
Old 15 Jun 2015, 06:37 am
Fresh Cruiser
 
Join Date: Jun 2015
Posts: 5
Default Re: Couple of issues...

I checked all the fuses in the box with a multimeter, cleaned the contacts and it still has the same problem... Although today when I got to my car, I also found the battery had died and I couldn't switch the alarm off (until I completely disconnected the battery) it turned out the internal light doesn't switch off automatically anymore.
Reply With Quote
  #8 (permalink)  
Old 25 Jun 2015, 02:00 am
Young Cruiser
 
Join Date: Jan 2013
Location: Caerphilly, South Wales
Posts: 58
Default Re: Couple of issues...

On the headlight stalk you should have a small lever for changing the brightness of the instrument panel lights, the top position of this is a separate on/off switch for the big interior light. It could just be that.
Reply With Quote
  #9 (permalink)  
Old 07 Jul 2015, 12:23 pm
Fresh Cruiser
 
Join Date: Jun 2015
Posts: 5
Default Re: Couple of issues...

Ok, late reply but that was the problem... a real Duh moment from me!

I have one other question, regarding the fact I only have one key and my local Chrysler service place wants 100 for a new remote... I saw this on eBay for 49

CHRYSLER PT CRUISER ECUs / TRANSPONDER / ALL LOCKS & 2 KEYS 00-10 | eBay

Is it easy enough to replace all these parts? Can you just switch over the ECU's and Transponders in the 2001 model? Is it worth getting this for that price?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Limited, a couple of issues. Maybe related? Ether General PT Cruiser Discussions 7 23 Sep 2014 10:04 am
I need a couple Cruiser Quarterly back issues wwpptc Classifieds: Want To Buy 25 14 Apr 2012 08:49 pm
New Guy! Couple of Questions boothman Wheels, Tires, Suspension 2 31 Mar 2010 01:26 pm
A couple of questions ejstith General PT Cruiser Discussions 9 28 Aug 2009 11:13 am
Couple of questions JoeHundredAire Tech & Performance Forum 4 13 Apr 2009 07:06 pm


All times are GMT -5. The time now is 06:26 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors