PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Regional Forums > Europe PT Forum

PT Cruiser Forum

Advertisements
Pt cruiser 1.6 idle not stable

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01 Sep 2016, 12:53 pm
Fresh Cruiser
 
Join Date: Aug 2012
Posts: 9
Default Pt cruiser 1.6 idle not stable

Hi all

I have problems in my pt cruiser.
Idle seems not to be as stable as it should and when I start running the motor seems to go down and loose power.

I am not expert on it but I checked the 02 sensor with a OBD2 tools and it goes up and down all the time un idle

Is it normal?



Any help?

Thanks
Reply With Quote
  #2 (permalink)  
Old 01 Sep 2016, 01:04 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,301
Default Re: Pt cruiser 1.6 idle not stable

Be aware most members here have 2.4 engines.

Engine light on? If so what are the codes?

How many miles?

Has it gradually been losing power? If so you might want to check and see if your exhaust is restricted.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 01 Sep 2016, 03:05 pm
cruserdad1976's Avatar
Obsessed Cruiser
 
Join Date: Sep 2009
Location: st james mo
Posts: 8,217
Default Re: Pt cruiser 1.6 idle not stable

just asking but

Year?
Miles?
what has been done?
Model well the 1.6 says it is not in the states.
where are you located?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT cruiser overheat at idle Fable55255 Tech & Performance Forum 10 28 Oct 2017 08:11 am
2007 PT Cruiser rough idle J2007 Tech & Performance Forum 4 25 May 2016 09:36 am
PT Cruiser rough idle J2007 Canada PT Forum 3 25 May 2016 12:22 am
HELP...Cruiser sputtering at idle mahgninnuc68 Tech & Performance Forum 11 09 Mar 2012 07:02 pm
06 cruiser idle/fan problems TFD Tech & Performance Forum 10 10 Jul 2009 07:26 am


All times are GMT -5. The time now is 06:50 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors