PT Cruiser Forum

PT Cruiser Forum (http://www.ptcruiserlinks.com/forum/)
-   Europe PT Forum (http://www.ptcruiserlinks.com/forum/europe-pt-forum/)
-   -   2.2 DIESEL fine when started the erratic after revving (http://www.ptcruiserlinks.com/forum/europe-pt-forum/64062-2-2-diesel-fine-when-started-erratic-after-revving.html)

grandads_shed 10 Jul 2017 11:55 am

2.2 DIESEL fine when started the erratic after revving
 
1 Attachment(s)
just bought my self a 2002 Pt cruiser 2.2 crd. im in the uk.
now the problem is ,
when i start the car the tickover is smooth, but as soon as i rev it it acts as though it is misfiring. and tickover is as rough as hell.
if i turn the engine off then turn the key to start it , i have to wait about 10 - 15 seconds before i can get it to even turn over and start again, (no light dim when i turn the key, it just wont turn the starter motor .)
whilst running if i turn on the heater / aircon etc the revs drop quite a bit..
i have just put in a new diesel filter as the old one was leaking out around the seal.

the engine management light is not on, but do work.

it seems like, when i rev it the fuel pressure drops, and when the engine is off and i turn the key to the run position for 10 to 15 seconds the fuel pump comes on and the pressure rises the fuel system,
start the car and its smooth again until i give it sum revs, at one point it would not rev above 3000rpm , other times it will rev past 3000rpm, the roughness starts around 1200 to 1500rpm ,

would get a video but being a new member i dont know if i can link to it from youtube,

http://www.ptcruiserlinks.com/forum/...1&d=1499705654

_PTGT03 10 Jul 2017 03:54 pm

Re: 2.2 DIESEL fine when started the erratic after revving
 
if you're trying to link a youtube video, just copy the share URL and paste it into your next post.

Did the diesel ever come turbo ? I'm wondering if the performance can be souped up to rival the 2.4 gasoline turbo ?

grandads_shed 11 Jul 2017 05:45 am

Re: 2.2 DIESEL fine when started the erratic after revving
 
Quote:

Originally Posted by _PTGT03 (Post 660637)
if you're trying to link a youtube video, just copy the share URL and paste it into your next post.

Did the diesel ever come turbo ? I'm wondering if the performance can be souped up to rival the 2.4 gasoline turbo ?

Thank you , i will try to make the vid in the next couple of days and upload to youtube

grandads_shed 12 Jul 2017 08:57 pm

Re: 2.2 DIESEL fine when started the erratic after revving
 
found out how to pull the error codes and got these.

what is [ Powertrain Induced Chassis Pitch Output Circuit ]

p0070 ambient air temperature sensor

P0100 MAF Sensor Ckt. Insufficient Activity

P0620 Generator Control Circuit Malfunction
[[ P0620 code means there is an abnormal voltage reading coming from the ECM often due too a faulty, generator or voltage regulator. ]]


P1652 Powertrain Induced Chassis Pitch Output Circuit


P1685 Driver 5 Line 5

Alfie1 13 Jul 2017 02:31 am

Re: 2.2 DIESEL fine when started the erratic after revving
 
It could be as simple as a split in the turbo intake tube which is the most common fault on a CRD, it can be made worse by slightly doughy engine mountings and the engine moving a bit.

I'd certainly start by checking this hose as it costs nothing (and I like free).

Best of luck
Tom

grandads_shed 14 Jul 2017 11:18 am

Re: 2.2 DIESEL fine when started the erratic after revving
 
Quote:

Originally Posted by Alfie1 (Post 661065)
It could be as simple as a split in the turbo intake tube which is the most common fault on a CRD, it can be made worse by slightly doughy engine mountings and the engine moving a bit.

I'd certainly start by checking this hose as it costs nothing (and I like free).

Best of luck
Tom

thx will look at that ,
cant get under the car yet,
did read on another forum that a duff battery can cause it , checked the voltage on mine today and its down to 11.7v , so fitted another battery but it made no difference.
i think its to do with the fuel system but i could be wrong,
i did put in a new diesel filter and wondering if i have trapped some air in the system , i dont know if there was it would have moved though the pipes by now ,
the filter bowl was full when i fitted the new filter, but the old owner ran the engine with the filter unscrewed.
so there would have been some air in the pipes to the injectors etc ,
the confusing bit is it only runs rough after its been reved , when i start the car the tickover is nice and smooth.


All times are GMT -5. The time now is 04:51 am.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47