PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > Regional Forums > Europe PT Forum

PT Cruiser Forum

Advertisements
Problem with the radiator fan

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Dec 2020, 11:46 am
Fresh Cruiser
 
Join Date: Jul 2013
Posts: 2
Default Problem with the radiator fan

Periodically turn the fan on and off every few minutes.
2007 PT Cruiser
Reply With Quote
  #2 (permalink)  
Old 09 Dec 2020, 12:16 pm
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,595
Default Re: Problem with the radiator fan

Quote:
Originally Posted by ekaart View Post
Periodically turn the fan on and off every few minutes.
2007 PT Cruiser
What have you done to diagnose the problem?

Low engine coolant?
Check wiring going to radiator fan?
Check radiator fan by applying 12 volts to it directly?
Check ground wires going to driver's side fender?
Check for engine diagnostic codes?
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #3 (permalink)  
Old 10 Dec 2020, 01:27 am
Fresh Cruiser
 
Join Date: Jul 2013
Posts: 2
Default Re: Problem with the radiator fan

Quote:
Originally Posted by ptcruisersteve View Post
What have you done to diagnose the problem?

Low engine coolant?
Check wiring going to radiator fan?
Check radiator fan by applying 12 volts to it directly?
Check ground wires going to driver's side fender?
Check for engine diagnostic codes?
Thank you!
Reply With Quote
  #4 (permalink)  
Old 10 Dec 2020, 01:47 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,595
Default Re: Problem with the radiator fan

Quote:
Originally Posted by ekaart View Post
Thank you!
Post what you find out. We are here to help you.
__________________
If at First You Don't Succeed - Try, Try Again
Reply With Quote
  #5 (permalink)  
Old 10 Dec 2020, 11:56 pm
Macgyverman1123's Avatar
Cool Cruiser
 
Join Date: Nov 2017
Location: Raleigh, N.C.
Posts: 320
Default Re: Problem with the radiator fan

I've dabbled in radiator fans on the PT many a time. First, check the fan relays, there will be two. One for high speed,none for low. On 1st gen cars, they are in the relay box, on 2nd gen cars, they are on the side of the radiator. Next, you should disconnect the power connector and have a look inside. This was the cause of the same issue for me. Lastly, realize that the fan does cycle on and off weirdly, and sometimes very quickly, based on need, such as engine temp, and also based on the needs of the AC compressor. What exactly is yours doing?
__________________
-John P.
Go Canes! #TakeWarning
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator fan problem Bildam General PT Cruiser Discussions 9 14 May 2012 08:02 pm
Radiator Fan and A/C problem PTBluiser Tech & Performance Forum 4 09 Dec 2010 01:18 pm
Radiator problem jpassons Tech & Performance Forum 4 16 Oct 2010 07:07 am
ODD RADIATOR FAN PROBLEM barryrobinette Tech & Performance Forum 5 25 Aug 2010 07:50 am
Radiator fan problem moparman3 Turbo Performance 0 29 Oct 2009 08:23 am


All times are GMT -5. The time now is 12:57 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors