PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Exterior Accessories Forum

PT Cruiser Forum

Advertisements
HID kit install problem.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Jun 2008, 07:00 pm
DragonCruiser's Avatar
Fresh Cruiser
 
Join Date: Jun 2008
Location: Central Illinois
Posts: 14
Default HID kit install problem.

Hey i have a 07 PT, im having some trouble with my hid kit. I got around to installing it today and am having a problem. It is a xentac kit for what its worth. The kit works just fine while the car is not running, but once i start the PT the hid's flicker 4 times then turn off and wont come back on unless the car is turned off. Does anyone have any insight into what may be causing this problem? Any Ideas? Any help is greatly appreciated.
Reply With Quote
  #2 (permalink)  
Old 02 Jun 2008, 10:14 pm
StoneWhitePT2's Avatar
Cool Cruiser
 
Join Date: May 2007
Location: Baton Rouge, LA
Posts: 441
Default Re: HID kit install problem.

is it getting its power from the headlight bulb socket or directly from the battery...? cause if its from the OEM socket where ur getting ur power from, It is known to do that simply because u have other accessories on the car thats pulling juice and the ballasts cant get a qick fix of juice. I recommend that you get a relay kit from ur seller that gets power directly from ur battery....
__________________
--See My PT In Action!!! http://www.youtube.com/watch?v=ppP_V9udtho

2002 Custom Dream Cruiser Series 5 Rollin 22s/20s
Reply With Quote
  #3 (permalink)  
Old 03 Jun 2008, 08:46 pm
DragonCruiser's Avatar
Fresh Cruiser
 
Join Date: Jun 2008
Location: Central Illinois
Posts: 14
Default Re: HID kit install problem.

I was using the stock harness for power.
Went ahead and ordered the relay harness. I figured that was the issue. What clued me off was when the radar detector was shutting off when id turn on the lights. Thanks for the info buddy.Ill be sure and post pics once i get them put back in.
Reply With Quote
  #4 (permalink)  
Old 03 Jun 2008, 11:16 pm
Cool Cruiser
 
Join Date: Dec 2007
Posts: 369
Default Re: HID kit install problem.

did the high beams come on after lights shut off? the 06+ pts have a safety feature that if something goes wrong in the headlamp circuit , the headlamp circuit will shut down (computer controlled) and the high beams will come on in an effort to get you home. with these new CAN vehicles, you need a special digital harness (tells computer that everything is OK draw wise) to make the aftermarket HID light kits work as Plug and Play units.
__________________
06 Touring Edition NA/Auto. Airaid intake, Magnaflow Stainless cat-back exhaust, Taylor Thundervolt plug wires, rear lowered 1.75" with H&R Springs.
Yep, buying parts I cant afford with money I dont have to impress people I dont like anyways.
Reply With Quote
  #5 (permalink)  
Old 07 Jun 2008, 05:26 pm
DragonCruiser's Avatar
Fresh Cruiser
 
Join Date: Jun 2008
Location: Central Illinois
Posts: 14
Default Re: HID kit install problem.

Got the Kit working last night! Thanks for the help, they look great. I will get some pics up soon for everyone.
Reply With Quote
  #6 (permalink)  
Old 20 Feb 2009, 12:47 pm
outfit's Avatar
Cool Cruiser
 
Join Date: Feb 2008
Location: Sinton Texas
Posts: 221
Send a message via Yahoo to outfit Send a message via Skype™ to outfit
Default Re: HID kit install problem.

I have a quick question for you. Did you get the problem fixed the the battery harness? The reason I ask isI have an 06 PT touring and it is doing the same thing... Let me know something if you can...........
__________________
<---- Just installed.
2006 PT Cruiser Touring Non-Turbo
3 -Hyper White Thin Flexible 5mm LED Dome Lights from Oznium Damn they make a dif in the inside ,let me tell you the best led lights you can buy
1 -Hyper White 921 Superstar Bulbs from Autolumination
1 -Hyper White T10 Wedge 194 (Lic Pllate) Super White LED from Autolumination

Pioneer Head unit W/ HD & Satellite radio

2 - 7inch DVD/Headrests Monitors... dvd players built in the headrests
HID Lights 8000k 9006 for lows from xhidoutlet....
HID Slim 55w 6000K for high's from HIDGEEK.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
$50 (paypal) to whoever can solve my A/C problem intend Tech & Performance Forum 5 03 May 2008 08:08 pm
Problem with strut install hifiman Wheels, Tires, Suspension 6 11 Aug 2006 05:55 pm
stage 1 install problem gooberff Stage Turbo Kits 6 29 Jun 2005 12:22 am
Anyone install their own Mopar hitch receiver? crazie.eddie General PT Cruiser Discussions 6 06 Oct 2004 10:15 pm
Rear Sway Install Problem divots Turbo Wheels/Suspension/Handling 6 06 Jul 2003 01:57 pm


All times are GMT -5. The time now is 04:00 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors