PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Exterior Accessories Forum

PT Cruiser Forum

Advertisements
anybody installed LED's in talllights

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12 Feb 2009, 01:02 am
Young Cruiser
 
Join Date: Jan 2008
Posts: 55
Default anybody install LED's in talllights

so drove from Austin to Corpus Christi, Tx one night and got stopped four times for a burned out brake light.

SO before I go buy just the regular bulbs I thought about upgrading to LED's

SO what are your guy's experience with them?

I know most likely I'll need to get load balancers, I'm just curious about the light output.
Reply With Quote
  #2 (permalink)  
Old 12 Feb 2009, 07:39 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,719
Default Re: anybody installed LED's in talllights

Auto zone has a whole stock of LED's that are exact replacement for normal auto bulbs. I don't think you need any kind of load balancers. I have the rocket tail lights and replaced the brake/running lights with the LED's and they work fine.

__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #3 (permalink)  
Old 12 Feb 2009, 08:17 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,504
Default Re: anybody installed LED's in talllights

I have direct replacement LEDs in the tail/stop light. Only if you replace the turn signal do you need balancers (or else your turn signals will be strobes).
The tail light is every bit as bright, but when I step on the btake, it's LOTS brighter.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 12 Feb 2009, 08:50 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 27,719
Default Re: anybody installed LED's in talllights

Quote:
Originally Posted by quicksilverdon View Post
Only if you replace the turn signal do you need balancers (or else your turn signals will be strobes).
Forgot to add that I replaced the turn signal bulbs with Halogen for just that reason.
__________________
........
...just CREWZIN along! . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 123,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Cruiser Of The Month (COTM) May, 2015.
Visit My Home Page www.CREWZIN.com
I find it ironic that the colors red, white, and blue stand for freedom until they are flashing behind you.
Reply With Quote
  #5 (permalink)  
Old 20 Feb 2009, 05:56 pm
Fresh Cruiser
 
Join Date: Dec 2008
Posts: 2
Default Re: anybody installed LED's in talllights

The only problem from LED replacement bulbs is some cars will get warning lights on in the dash that the bulb is out. Otherwise, they work good. Make sure you get the ones with the SMD leds in them.
__________________
LED Lighting blog
Reply With Quote
  #6 (permalink)  
Old 01 Mar 2009, 03:13 am
Fresh Cruiser
 
Join Date: Jan 2009
Posts: 29
Default Re: anybody installed LED's in talllights

interesting read u learn somthing new u might use in the future everyday....

SMD??
Reply With Quote
  #7 (permalink)  
Old 01 Mar 2009, 11:52 am
brightlight07's Avatar
Regular Cruiser
 
Join Date: Oct 2008
Posts: 162
Send a message via Yahoo to brightlight07
Default Re: anybody installed LED's in talllights

i put the direct replacement led bulbs from autozone and yeah theyre bright but i took them right back out and put the og back in becuz they dont fill out the circle they are supposed to...and they dont seem to be as bright as the og
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Psi-Fi PowerPaq installed. WOW!!! ksquared11 Turbo Performance 17 13 Jan 2008 04:26 pm
2004 Dodge SRT4 FS Chicagoland w/Chromoly roll bar installed! newbee101 Classifieds: For Sale/Trade 0 08 Nov 2007 02:15 pm
Pillar Pod and Gauges installed Mean Green Turbo Performance 25 12 Nov 2004 01:38 am
REQ: Images of Overhead Console Unit Installed neps Interior Accessories Forum 0 22 Jun 2004 07:42 pm
TurboXS RFL BOV and AGPTurbo BOP installed!! RobGT Turbo Performance 1 23 Jun 2003 06:38 pm


All times are GMT -5. The time now is 09:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors