PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Exterior Accessories Forum

PT Cruiser Forum

Advertisements
hatch problems

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Jun 2009, 08:52 pm
superpug666's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: quebec
Posts: 163
Default hatch problems

hi guys... i need your opinions on why my hatch door "clunks" when i open it. I really have to almost force it, and sometime it barely makes any noises....i looked at everything i can and everything looks good.....HELP! lol
__________________
I drive an hybrid, it burns both gas and rubber!!!!!

To hell with all religions!

Yes my baby is stock, for now!
Reply With Quote
  #2 (permalink)  
Old 17 Jun 2009, 07:48 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: hatch problems

What year? Up until '05, the latch was mechanical, then it went electrical.
I'll assume yours is mechanical. I'd get some silicone spray and apply generously to all parts of the latch mechnism you can get at.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 17 Jun 2009, 04:45 pm
superpug666's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: quebec
Posts: 163
Default Re: hatch problems

Quote:
Originally Posted by quicksilverdon View Post
What year? Up until '05, the latch was mechanical, then it went electrical.
I'll assume yours is mechanical. I'd get some silicone spray and apply generously to all parts of the latch mechnism you can get at.

it is indeed, i have an 04GT...the latch works proprely because it unlocks wellthe first few inches are ok..its the rests.....thanks!
__________________
I drive an hybrid, it burns both gas and rubber!!!!!

To hell with all religions!

Yes my baby is stock, for now!
Reply With Quote
  #4 (permalink)  
Old 17 Jun 2009, 07:59 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: hatch problems

So it unlatches OK? Look carefully at the hydraulic struts. See if they're loose or defective.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 17 Jun 2009, 08:07 pm
superpug666's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: quebec
Posts: 163
Default Re: hatch problems

Quote:
Originally Posted by quicksilverdon View Post
So it unlatches OK? Look carefully at the hydraulic struts. See if they're loose or defective.

they black part is starting to be rusty....and i aint sure about the way they "sit" where they bolt up....looks crouked to me, but i looked at a hatch on ebay and on the pic it looked off too......
__________________
I drive an hybrid, it burns both gas and rubber!!!!!

To hell with all religions!

Yes my baby is stock, for now!
Reply With Quote
  #6 (permalink)  
Old 18 Jun 2009, 07:44 am
Young Cruiser
 
Join Date: Jun 2009
Posts: 80
Default Re: hatch problems

I hate to admit it, but when mine did this about a month ago it turned out that I had closed a freakin screwdriver in the seam on the right which jammed the liftgate to the bodypanel. Check to see if there's some kind of obstruction, or if the beauty panels have come loose and are sticking.

If there's nothing obstructing the motion then I'd replace the gas springs that provide the counter-force needed to lift the gate. Over time they age and the seal leaks slowly. Once the nitrogen in the cylinder is depleted they will no longer "spring" and can jam internally, which may be the cause of your sticking and clunking when you open it, loss of the pressure in the cylinders themselves will cause the liftgate to "feel" heavier and make it harder to open.

$27 ea (+tax) at AutoZone
Reply With Quote
  #7 (permalink)  
Old 18 Jun 2009, 08:40 am
superpug666's Avatar
Regular Cruiser
 
Join Date: Aug 2008
Location: quebec
Posts: 163
Default Re: hatch problems

Quote:
Originally Posted by Jabouty View Post
I hate to admit it, but when mine did this about a month ago it turned out that I had closed a freakin screwdriver in the seam on the right which jammed the liftgate to the bodypanel. Check to see if there's some kind of obstruction, or if the beauty panels have come loose and are sticking.

If there's nothing obstructing the motion then I'd replace the gas springs that provide the counter-force needed to lift the gate. Over time they age and the seal leaks slowly. Once the nitrogen in the cylinder is depleted they will no longer "spring" and can jam internally, which may be the cause of your sticking and clunking when you open it, loss of the pressure in the cylinders themselves will cause the liftgate to "feel" heavier and make it harder to open.

$27 ea (+tax) at AutoZone
thanks man! but i wont go at autoszone, altho id love to....kinda hard up here because that store doesnt exist.....ill try canadian tire or UAP/NAPA!
__________________
I drive an hybrid, it burns both gas and rubber!!!!!

To hell with all religions!

Yes my baby is stock, for now!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hatch latch malfunction Dragula General PT Cruiser Discussions 10 26 Mar 2011 03:37 pm
Pop the rear hatch open using the remote zapwizard Exterior Accessories Forum 4 28 Jun 2007 08:32 pm
Rear Hatch Opener Install ? StevenAndEva Sound and Security Forum 1 24 Feb 2006 12:23 pm
Handles for Rear Lift Hatch Dundevil Exterior Accessories Forum 6 05 Aug 2003 04:59 pm
Hatch no longer turns inside lights on Dalite General PT Cruiser Discussions 3 28 May 2003 12:17 pm


All times are GMT -5. The time now is 06:49 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors