PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > Exterior Accessories Forum

PT Cruiser Forum

Advertisements
Another Electrical Question - Rapid Flashing signals

 
Like Tree4Likes
  • 2 Post By Sinbad
  • 1 Post By rckstein
  • 1 Post By soonercruiser

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Nov 2018, 12:00 am
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 6,910
Lightbulb Another Electrical Question - Rapid Flashing signals

Converted all the tail light bulbs to LEDs on the Panel Van Project.

The turn signals are blinking very rapidly, almost like when there is a short in a bulb.
But, all the bulbs are working fine.
** And, the hazard flasher are flashing at the normal rate.

I've never had a problem with conversion to LEDs before.
Thoughts???
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
  #2 (permalink)  
Old 10 Nov 2018, 01:39 am
Sinbad's Avatar
Cool Cruiser
 
Join Date: Sep 2016
Posts: 484
Default Re: Another Electrical Question - Rapid Flashing signals

You need LED's with resistors - the car thinks you have a bulb gone because the LED doesn't register as drawing current. Ergo, it blinks rapidly to warn you.

Quite honestly I'd put the old standard indicators back in and forget it - LED's will save you power draw when you use them for main lighting but for indicators they aren't worth the aggravation.
rckstein and Alfie1 like this.
__________________
_________________________________________
'07 2.2 CRD

Bollocks to Brexit
Reply With Quote
  #3 (permalink)  
Old 10 Nov 2018, 07:44 am
rckstein's Avatar
Obsessed Cruiser
 
Join Date: Dec 2010
Location: Texas
Posts: 14,801
Default Re: Another Electrical Question - Rapid Flashing signals

When I was researching the hyper-flashing when I switched to LED Sweeplites for the rear turn signals, I came across a post somewhere where that person was able to fix their hyper-flash issue on a Gen1 PT by replacing the turn signal flasher. The Gen1 has a replaceable turn signal flasher where the Gen2 it's built into the instrument cluster.

I happen to come across this flasher module for the Gen1:

https://www.diodedynamics.com/led-fl...t-cruiser.html

https://www.amazon.com/2001-2005-Chr.../dp/B00KQV1606
soonercruiser likes this.
__________________

'06 Touring Edition NA Automatic
160k Miles / Electric Blue Pearl
USMC '82 - '93

Last edited by rckstein; 10 Nov 2018 at 07:54 am.
Reply With Quote
  #4 (permalink)  
Old 10 Nov 2018, 07:43 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 6,910
Thumbs up Re: Another Electrical Question - Rapid Flashing signals

Quote:
Originally Posted by rckstein View Post
When I was researching the hyper-flashing when I switched to LED Sweeplites for the rear turn signals, I came across a post somewhere where that person was able to fix their hyper-flash issue on a Gen1 PT by replacing the turn signal flasher. The Gen1 has a replaceable turn signal flasher where the Gen2 it's built into the instrument cluster.

I happen to come across this flasher module for the Gen1:

https://www.diodedynamics.com/led-fl...t-cruiser.html

https://www.amazon.com/2001-2005-Chr.../dp/B00KQV1606
Thanks Rocky!
I knew someone would have the easy fix!
I found a new one on eBay for $16.79......
rckstein likes this.
__________________
Frank, aka SOONERCRUISER,

2011 GWE Dodge Challenger SRT8 as Show Car
2003 PT Cruiser GT Panel Van Conversion as new day driver.

Have now owned 6 PT Cruisers = Me PT Crazy!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Electrical Question genther General PT Cruiser Discussions 10 14 Nov 2014 05:21 pm
Rapid clicking from starter won't start joebullits General PT Cruiser Discussions 6 24 Aug 2012 07:09 pm
03 gt electrical question jacarc1 General Turbo Discussions 3 27 Mar 2010 06:19 pm
electrical system question Thrusst Turbo Performance 1 09 Aug 2007 06:52 am
Bye Bye Rapid Craft CREWZIN Vendors & Buyers Forum 1 31 Jul 2003 12:02 am


All times are GMT -5. The time now is 12:00 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors