PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Noise from suspension???

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Feb 2006, 10:23 am
Fresh Cruiser
 
Join Date: Feb 2006
Location: Dubai.
Posts: 10
Default Noise from suspension???

I have this loud creaking noise coming from suspension area whenevr the car has been used for more than 15 minutes. It only comes when I am turning at very slow speed, like in a parking lot while turning nto a parking lot. It does not sound like a bad drive shaft, but more of like a rusty door hinge kinda sound. If its the drive shaft, often the sound will sound like few clicks while doing a full turn (uturn), but my car does not sound when doing u turn. I think that my suspension coils needs some grease, etc..but i dont know. anyone has experience???

secondly, is it normal for a pt cruiser to slighltly vibrate when accelarating on initial drive off? like from a stop to a drive off. i feel like a lsight wobble on my left front wheel then as teh speed gets fasterm the wobble is not apparent anymore. The dealer tols me that this is normal for all Pt cruisers. even the new ones have em. Is this true?

Thirdly, when idle (traffic lights), is it normal for the engine to shake intermittently like every 3 seconds. the rev meter is constant though at 0900 rpm. but the engine jerks/shake as if like a misfire. However, i have cleaned the injectors/throtthle body, changes new sparkplugs and wire. but problem still there. The dealer says its normal for this car. I beg to differ!

anyone can give comments/advise/piossible remedies? btw, my model is the baseline 2001 automatic with 68,000 miles.
Reply With Quote
  #2 (permalink)  
Old 06 Feb 2006, 10:44 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Welcome - you're the second owner from Dubai that I know of.
Have your ball joints checked for the noise.
You say wires & plugs were done - how long ago and with what? The stock wires are real garbage.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 06 Feb 2006, 08:23 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default

ruzz1, welcome to the Forum, enjoy!!!![^]

None of the conditions you describe are NORMAL for a PT. I assume that your choice of dealers are slim to none, If there is more than one available to you, take it to another one.
Reply With Quote
  #4 (permalink)  
Old 07 Feb 2006, 12:23 am
Regular Cruiser
 
Join Date: Aug 2005
Location: Ca, USA.
Posts: 114
Default

Check out the topic I had started in the tech forums here...
http://www.ptcruiserlinks.com/forum/...TOPIC_ID=13832

Maybe there is a suggestion that can help you. I know there have been different people complaining about the same noises (just about) coming from the front.
__________________
2001 Ltd Ed. Inferno Red PT, many mods, many more to come.
Reply With Quote
  #5 (permalink)  
Old 08 Feb 2006, 04:39 pm
Fresh Cruiser
 
Join Date: Feb 2006
Location: Dubai.
Posts: 10
Default

I changed my spark plug and wires used by the dealer: MOpar products. just changed it a week ago.

on the wobbly/vibration tire feeling on initial drive off..anybody has experience? cud it be tie rods?
Reply With Quote
  #6 (permalink)  
Old 09 Feb 2006, 01:06 am
Regular Cruiser
 
Join Date: Aug 2005
Location: Ca, USA.
Posts: 114
Default

Never had THAT problem... hmmm what's the wear pattern look on your tires? Look normal? Maybe they might need to be aligned... badly? :P
__________________
2001 Ltd Ed. Inferno Red PT, many mods, many more to come.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Mysterious" turbo engine noise...??? Gary04GT Turbo Performance 76 21 Aug 2006 08:28 am
Finally Energy Suspension kit installed+result Ctown Wheels, Tires, Suspension 4 02 Jan 2005 03:53 pm
Road noise / exhaust noise in the car. jackatg450 Tech & Performance Forum 3 21 Jul 2004 10:55 pm
Air Bag Suspension Noise Question ptcruzin42 Wheels, Tires, Suspension 0 30 Oct 2003 07:49 pm
Autocrossing with air suspension renichms Tech & Performance Forum 2 12 Apr 2002 10:29 am


All times are GMT -5. The time now is 01:03 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors