PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
No Heat

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Sep 2006, 04:14 pm
Fresh Cruiser
 
Join Date: Sep 2006
Location: .
Posts: 2
Default No Heat

I have a 2001 Limited Edition PT that has little to no interior heat. Any suggestions?
Reply With Quote
  #2 (permalink)  
Old 21 Sep 2006, 04:20 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default

Move down here...don't need no stinkin heat other than what's outside.

Seriously, you could have air trapped in the anti-freeze system, a stuck lever that switches from cold to hot, a stuck open thermostat that not letting the water heat up.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 21 Sep 2006, 05:16 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

what year car ??
Reply With Quote
  #4 (permalink)  
Old 23 Sep 2006, 01:42 pm
thegoldpt's Avatar
Fanatic Cruiser
 
Join Date: Apr 2005
Location: Port Orchard, Washington
Posts: 771
Send a message via MSN to thegoldpt Send a message via Yahoo to thegoldpt
Default

2001...

I agree with CREWZIN.. The little i know about cars.. If you can't do it yourself, take it to a good mechanic.. Dealers suck.
Reply With Quote
  #5 (permalink)  
Old 23 Sep 2006, 01:55 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

i would think thermostat or heater core ?? any antifreeze leaking ?? or smell??
Reply With Quote
  #6 (permalink)  
Old 25 Sep 2006, 11:07 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Is the temp gauge at the 1/2 way mark? If it is, chances are thermostat is okay.
Antifreeze in overflow bottle? If not, you could have air in system.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 25 Sep 2006, 03:03 pm
Senior Cruiser
 
Join Date: Oct 2002
Location: Riverside, Ca, USA.
Posts: 1,372
Default

Seems to me no heat in the interior means heater core problem or at the very least no water in the heater core. Another thing could be that your vacuum controled doors are not working and you are not routing the hot air anywhere. Does the interior fan go on and can you hear your doors operating??
__________________
06 GT Auto, Cool Vanila Exterior, Presto Change O 3bl, Cargo Mat and Net, Billet Oil Cap, Yoko Avid 4Vs Tires, 03 GT Wheels, 4 Chrome Door Handle Screw Covers, MOPAR Mud Flaps, H&R Rear Sway Bar, Freedom Strut Tower Bar, Rear Door Sill Covers.
Reply With Quote
  #8 (permalink)  
Old 24 Jul 2007, 10:55 am
KIMS CRUZER's Avatar
Young Cruiser
 
Join Date: Sep 2003
Location: OH.
Posts: 88
Default Re: No Heat

If one doesnt hear the doors operating , what is this a indicator of? I just picked my PT up. It no longer overheats since a new fan, then a thermostat and radiator put on. Now I have no heat!
Reply With Quote
  #9 (permalink)  
Old 03 Nov 2011, 06:59 am
Fresh Cruiser
 
Join Date: Oct 2011
Posts: 7
Default Re: No Heat

i don't either! same senario..i took it in for overheating problems, they replaced the fluid, and flushed the system, and replaced the dual stage fan...now I discovered no heat! bet they forgot something...what have u found out radio4mike@bellsouth.net
Reply With Quote
  #10 (permalink)  
Old 03 Nov 2011, 10:41 am
Surf_Blu_Baby's Avatar
Regular Cruiser
 
Join Date: Jul 2011
Location: Kill Devil Hills, NC
Posts: 118
Default Re: No Heat

I had the same problem with my old Focus - turned out to be an extremely dirty heater core. Had a mechanic friend remove the heater core from the car and flush it out and presto - seriously burning heat like the car had never put out before! Car was a 2000 model and the flush was done late 2010 so after 10 years I'd expect that thing to need a cleaning - watch out thou cause the shop I was taking the Focus to just wanted to replace the heater core which translated into big bucks while having an experienced mechanic friend work on it only cost me a few lunches...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle with Heat on Carchrism5 Tech & Performance Forum 2 05 Dec 2005 11:14 am
heat and fan control ~ what to expect on 1 and 2 ? frances General PT Cruiser Discussions 7 22 Dec 2004 09:09 am
heat GTCOOL Stage Turbo Kits 12 13 Jun 2004 05:59 pm
Arizona heat Geeksterman Turbo Performance 4 29 May 2003 07:08 pm


All times are GMT -5. The time now is 11:33 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors