PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
03 PT trouble

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 21 Feb 2007, 07:52 pm
Fresh Cruiser
 
Join Date: Feb 2007
Location: Springboro, ohio, USA.
Posts: 2
Default 03 PT trouble

ok, first time here, but. I have a 03 electric blue PT. It is a standard only extra was the window tint and the AM/FM CD raido. Just after it turned over 36015 miles the demons took over. Dome light came on, gauges went to zero, indicator lights came on & the noise indicator sounded. Of course the first time the dealer could not find anything. Few days later, it happens again and the dealer got it back and they found part of cluster bad, after 2 weeks of-ordering part-and them repairing it(they did do this under warranty for me even though just over mileage limit) It was fixed......or so I thought. 1 year and 1 month later it's doing it again. "Sorry, no warranty you'll have to pay" Can't say I'm very happy. Last year I put around $600.00 into it just in repairs. Plat. plugs and wires, plinum gaskets, 2 different sensors. I was hoping for better stability in a vehicle. Any input on this would be greatly appreciated!!!!!!!!!!!!
Reply With Quote
  #2 (permalink)  
Old 21 Feb 2007, 08:54 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default

Gina,

WELCOME to the forum. Too bad it's not under better circumstances. The dealer did fix the problem and it lasted a year, so you know what the problem is this time. Why that part of the cluster is going bad on you is another matter. I've never heard of that particular set of happenings from a cruiser and I'm on all kinds of PT related sites. If I were you I'd get ahold of the district manager with all the paperwork from the first time and yell/scream/cry that it's the same problem you already had before. That maybe the dealer only gave you a temporary fix. Can't hurt to raise a stink and maybe get a sympathetic ear from the manager.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 22 Feb 2007, 08:20 am
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 952
Default

CALL CHRYSLER DIRECT!! CUSTOMER SERVICE<, they are actually pretty good a reasonable.They will listen & work with you. [8)]Even well past warranty with a good case,[)]
Reply With Quote
  #4 (permalink)  
Old 22 Feb 2007, 10:23 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Welcome, Gina.
Agree with the others.
I'm on every PT Forum I know of (with Crewzin) and haven't heard of your particular problem. Are all the symptoms the same as a year ago?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 22 Feb 2007, 02:06 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

welcome !! like mentioned above call chrysler direct keep us posted
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble with fog light switch? twins4me General PT Cruiser Discussions 18 22 Nov 2009 04:44 pm
Trouble shifting into 3rd gear on 5-speed GT purplept General Turbo Discussions 23 28 May 2004 12:00 pm
trouble code Paw General Turbo Discussions 21 20 Oct 2003 11:46 pm
Anyone have trouble with this forum? Retro General PT Cruiser Discussions 3 20 Oct 2003 12:55 am


All times are GMT -5. The time now is 07:42 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors