PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Sudden whining out of my turbo pt

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Mar 2007, 08:48 pm
Fresh Cruiser
 
Join Date: Mar 2007
Location: rochester, mi, USA.
Posts: 2
Default Sudden whining out of my turbo pt

I lease a turbo pt 2005....today i was driving and decided to pass someone.....and while accelarating a loud whining noise came out of the engine area....something i never heard before.......it went away when i was driving normal....but any accelaration and the the loud whing noise came alive again.....i will take it in to the dealer tomorrow....but since it is 10 miles away im afraid it mite not make it.......anyone have a clew to my problem....???? TIA
Reply With Quote
  #2 (permalink)  
Old 12 Mar 2007, 07:48 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Welcome, Cyndy-
Whining or a screech? Whining might be a slipping belt. [:I]
Do let us know what dealer finds.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 12 Mar 2007, 11:28 am
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

welcome to the board, like don said maybe a belt and not the turbo ?? was it raining or or damp maybe it was the belt squealing ?? let us know what happens good luck !!
Reply With Quote
  #4 (permalink)  
Old 12 Mar 2007, 03:12 pm
Fresh Cruiser
 
Join Date: Mar 2007
Location: rochester, mi, USA.
Posts: 2
Default

well i took it in this morning......and while i was driving to the dealer....the noise disappeared but the turbo wasnt kicking in any more......and a couple of hours later the dealer sed we gotta replace da turbo ......bad bearing in the turbo........well thats a relief.....he never saw that problem before......all covered under da warrantee..........5 years or 50000 miles corinthean leather....not......snort
__________________
cyndy
Reply With Quote
  #5 (permalink)  
Old 12 Mar 2007, 03:52 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

I think that's only the second or third turbo failure I've read about.
Do you use synthetic oil? You should....
Glad you're under warranty.[?]
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #6 (permalink)  
Old 12 Mar 2007, 08:05 pm
Cool Cruiser
 
Join Date: Oct 2005
Location: northern, ca.
Posts: 209
Default

Quote:
quote:Originally posted by quicksilverdon

I think that's only the second or third turbo failure I've read about.
Do you use synthetic oil? You should....
Glad you're under warranty.[?]
my turbo failed at 25,000 miles. i think what it boils down to is - either you get a good or bad turbo from the factory/chrysler's supplier. although i use synthetic oil, i don't think the use of synthetic matters on turbos (like mine) that fail well before 30,000 miles. chrysler should investigate their turbo supplier. if the turbos are hand assembled, maybe there is a procedure flaw in the fitment of the bearing(s). my 2 cents.
__________________
gt model, modified airbox with cold air induction, magnecor plug wires, tyc b/up lenses, chrome grille kit, retro 3d taillights painted steel blue, buick-style portholes, nomad chevy trunk trim, blue interior light strips, and massive turned down diesel-type exhaust tip.
Reply With Quote
  #7 (permalink)  
Old 13 Mar 2007, 07:55 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Quote:
quote:Originally posted by pppt03turbo
although i use synthetic oil, i don't think the use of synthetic matters on turbos (like mine) that fail well before 30,000 miles. chrysler should investigate their turbo supplier. if the turbos are hand assembled, maybe there is a procedure flaw in the fitment of the bearing(s). my 2 cents.
Have to agree with you. I meant it for long term longevity of the turbo, now that he's getting a new one. To fail so soon is clearly a manufacturing flaw.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #8 (permalink)  
Old 13 Mar 2007, 11:21 am
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

glad you got it fixed and lets hope no other troubles for you !! [^]
Reply With Quote
  #9 (permalink)  
Old 20 Mar 2007, 11:38 am
Fresh Cruiser
 
Join Date: Mar 2007
Location: .
Posts: 2
Default

Mine started whirring the other day. Checked all fluids, they are fine, but with the whirring, I get a popping noise as well. First thing my hubby said was bad bearing in the turbo. Unfortunately, mine is no longer under warranty. (Road warrior here....lol)Just wondering if any of ya'll know if that would fall under powertrain? I am guessing not, but worth a shot........it (the whirring and popping sound) is usually really loud with acceleration,(none when idling, except the popping rattling noise, almost like a loose something) but it doesn't really accelerate well going uphill. Any suggestions? (FYI, it used to do an engine rev on its own) BTW, it is an 05 Convertible Touring, Light Almond.
Reply With Quote
  #10 (permalink)  
Old 20 Mar 2007, 02:52 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default

Rayvn, I'd still try the dealer. You never mentioned how many miles you have on it. It would be a streach, BUT maybe it would be covered under emission warranty.

BTW: Welcome to the Forum[^] [^] [^]
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blow Off Valve Conversion Kit gonzomania Tech & Performance Forum 10 08 Sep 2004 09:08 am
How lucky was I? (BOV install) alceryes General Turbo Discussions 27 18 Jul 2004 11:29 am
Turbo leaking oil 03baggedturbo Turbo Performance 5 09 Dec 2003 09:54 pm
2003 PT Turbo Review by AUTOTEST FILE Gary04GT General Turbo Discussions 2 12 Jul 2003 09:14 am
Chrysler to Offer New Cheaper GT Turbo skylight PT Cruiser News and Rumors 19 12 Jun 2003 02:04 pm


All times are GMT -5. The time now is 11:50 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors