PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
I broke my PT

 
Closed Thread
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09 Dec 2003, 06:36 pm
Fresh Cruiser
 
Join Date: Jun 2003
Location: .
Posts: 34
Default I broke my PT

it was snowing the other day and i turn on
my rear window wiper and it got stuck ok fine so i turn it off
when i got home my whiper was still attach but it was now on the
body of the car and not the window[:0]

and now when i turn it on it just makes a clicking sound
What did i brake and how hard is it to fix ?

what do i need to what out for so the dealer fixes it right ???[:I]

do they have to take the rear hatch of ?? will it rattle after they put it back on ???
  #2 (permalink)  
Old 09 Dec 2003, 06:51 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default

that stinks !! hopfully it will not be a hard fix
  #3 (permalink)  
Old 09 Dec 2003, 08:36 pm
Dedicated Cruiser
 
Join Date: Oct 2003
Location: Jacksonville, NC, USA.
Posts: 2,612
Default

You may have just striped either the wiper arm or the motor shaft. You should not have to have the rear hatch removed to repair whatever is broken.
__________________

2002 Inferno Red PT Limited
Photos and more at: http://www.randgraphics.org/PT_Cruiser/demos/index.htm
Mercedes Wiki
  #4 (permalink)  
Old 09 Dec 2003, 08:57 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default

Quote:
quote:Originally posted by IRPT

You may have just striped either the wiper arm or the motor shaft. You should not have to have the rear hatch removed to repair whatever is broken.
I agree. That's what it sounds like. Should end up good as new.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
  #5 (permalink)  
Old 09 Dec 2003, 09:07 pm
Fresh Cruiser
 
Join Date: Dec 2003
Location: Tillsonburg, Ontario, Canada.
Posts: 46
Default

YES if they take apart the inside hatch panels it can all be fixed from there.
  #6 (permalink)  
Old 09 Dec 2003, 09:15 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,750
Default

Links,

I replaced the rear wiper with a faux handle since it doesn't rain a whole lot down here and when it does, I try and take the wife's car, and had to take the whole motor out to put the handle on. It only takes about 10 minutes and just a few screws, so the job isn't hard. Sorry, not selling the motor since I might have to put it back on in the future. If it clicks when you hit the button, try taking the wiper off (one nut when you take the center cap off) and see if the motor spline is turning), maybe you just stripped the blade handle itself and not harmed the motor. Good luck.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
  #7 (permalink)  
Old 10 Dec 2003, 01:36 am
Fresh Cruiser
 
Join Date: Jun 2003
Location: .
Posts: 34
Default

yes it clicks when you hit the button,
I was worryed about the dealership geting that rear panle back
on so that it does not start rattleing

thanks for your help
  #8 (permalink)  
Old 11 Dec 2003, 02:20 am
Fresh Cruiser
 
Join Date: Jun 2003
Location: .
Posts: 31
Default

Hello, we had the same thing happen to us.. it turned out that we just took off the cover and there was a nut that was loose.. we tightened the nut and everything is working great again.. gave us a scare though. Dont like it when new things seem to break like that. whew.
__________________
It\'s only a car, it\'s only a car, it\'s only a car, it\'s only a car, it\'s only a car...
-- my new mantra, now I only have to believe it.
  #9 (permalink)  
Old 11 Dec 2003, 02:36 am
Cool Cruiser
 
Join Date: Jan 2003
Location: .
Posts: 344
Default



Thanksfor the heads up about not using the rear wiper in Snow & Ice! Rear window defroster, and handheld ice scraper only from now on.
__________________
\'03 PT Turbo 2CN
Auto/Stick
Lt. Almond/cloth
Blanes HoodStruts
etc.
  #10 (permalink)  
Old 11 Dec 2003, 07:12 am
Cool Cruiser
 
Join Date: May 2003
Location: Prineville, Oregon, USA.
Posts: 386
Default

You guys actually take your cruisers OUTSIDE of the garage when it's raining/snowing??? No wonder your breaking things...also the cruiser might get dirty[)]
My wife just keeps shaking her head as I make my monthly car payment and stroll through the snow to the garage to LOOK at my cruiser as it takes up garage space. Little does she know that April will be here before too long

Deen

__________________
GT, 5-Spd, K&N filter, Stage I, AGP 3147 Big Turbo, DTEC Fuel Kit, Tial WGA, Greddy Profec EBC, DCR 55mm TB, 05 Plastic Manifold, 180 Deg. Stat, CCA FMIC, AMX hard-pipes, Water-Injection, STS shifter, Needswings 3\" DP w/dump and Borla Cat-back, BG Drop Springs, Eibach Sway Bars, Panther alloys & Eagle F1 Max-Performance Tires. Best run to date...12.93 @113.45MPH.
77 Blown Vette-runs 10\'s @ 136 MPH.
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
driver's recliner handle broke Carchrism5 Interior Accessories Forum 13 28 Jul 2015 09:22 am
Is it my fault? My PT is broke? PT Lilly General PT Cruiser Discussions 21 29 Aug 2012 09:35 pm
I finally broke down KingKole02 Sound and Security Forum 0 10 May 2004 10:05 am
congrats gary!! broke the 1,000 mark!! bobs turbo pt General PT Cruiser Discussions 7 03 Nov 2003 11:40 am


All times are GMT -5. The time now is 12:51 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors