PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Replace Multifunction Switch w/fog lamps

 
Like Tree4Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Jun 2007, 09:35 am
Fresh Cruiser
 
Join Date: Jun 2007
Posts: 1
Default Replace Multifunction Switch w/fog lamps

Old Part# - 04671594AD (2001 PT)
New Part# - 05073049AB (dated 6/2/07)
Cost to purchase at dealer - $63.45 plus tax
Install time - 30 minutes or less

Tools: Phillips screwdriver, small flat screwdriver, T10 torx

Remove negative battery cable
Move steering column to lowest tilt setting
Remove (2) phillips screws from underside of covering
Remove covering top and bottom and set aside
Remove (2) phillips screws on top inside
Remove (2) torx screws on right side
Pull wiper switch section out of your way to the right
Take small flat screwwdriver and pry out red locking tab on wiring harness
Pull out harness
Pull out old multifunction switch
Transfer foam dust circle to new switch (over lever)
Transfer flasher module (not included with new part)
Place multifunction switch back onto column
Install wiper section with the (2) small torx that were removed
Install (2) upper phillips screws
Install upper and lower plastic
Install (2) lower phillips screws
Connect battery and test.

Relatively simple install. Small red lock tab on harness is the most challenging part as the harness is in an awkward position. Nice to have headlights back or to be able to turn off your fog lamps.

Happy PT motoring

KG in Michigan
Reply With Quote
  #2 (permalink)  
Old 27 Jun 2007, 07:35 pm
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 23,092
Default Re: Replace Multifunction Switch w/fog lamps

Thanks for the Step-by-Step KG. I'm sure it will come in helpful for some owners that have yet to have their's burn up.
__________________
......
...just CREWZIN along! ฎ . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 117,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
NY Times article: http://www.nytimes.com/2008/10/30/au...30vintage.html
Reply With Quote
  #3 (permalink)  
Old 05 Sep 2007, 08:09 pm
Fresh Cruiser
 
Join Date: Sep 2007
Posts: 4
Default Re: Replace Multifunction Switch w/fog lamps

I have a 2003 LTD and am getting the damn fog lamps coming on thing! Draining the battery. Are we SURE it's the multifunction switch? Anyone know the 2003 part # on this? Danka

Also, does it help to unplug the lamps? or is it something else?

Last edited by cocojaja; 05 Sep 2007 at 08:35 pm.
Reply With Quote
  #4 (permalink)  
Old 06 Sep 2007, 06:22 am
CREWZIN's Avatar
Obsessed Cruiser
 
Join Date: Sep 2001
Location: West Central Florida
Posts: 23,092
Default Re: Replace Multifunction Switch w/fog lamps

If you don't want to replace the multifunction switch right now, take out the 15amp fuse #8 from the fuse box inside the car by your left knee. You won't have fog lights but they won't be draining your battery down anymore either.
__________________
......
...just CREWZIN along! ฎ . . . PT Cruiser Links Moderator
2000 PT. Original Owner, 117,000 miles
MY technical suggestions are given in GOOD FAITH without total guarantee, if in doubt go to a garage.
Visit My Home Page www.CREWZIN.com
NY Times article: http://www.nytimes.com/2008/10/30/au...30vintage.html
Reply With Quote
  #5 (permalink)  
Old 06 Sep 2007, 11:07 am
Fresh Cruiser
 
Join Date: Sep 2007
Posts: 4
Default Re: Replace Multifunction Switch w/fog lamps

Thanks!
bassmstrr likes this.
Reply With Quote
  #6 (permalink)  
Old 30 Dec 2009, 08:00 pm
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Default Re: Replace Multifunction Switch w/fog lamps

I took what KG posted for his 2001 Cruiser and added/updated various parts to reflect what I just went through on my 2005 Cruiser.

Old Part# - 04671870AD (2005 PT Convertible, Touring Edition, 2.4L Turbo, With Fog Lights)
New Part# - 05073049AB (dated 12/29/2009, same as back in 6/2007)
Cost to purchase at dealer - $142 including PA tax
Install time – around 30 minutes if you don’t stop to take notes and look things over.

Tools: Phillips screwdriver, small flat screwdriver, T10 & T20 Torx bits/screwdriver

• Put door windows down a couple of inches before disconnecting battery cable so you can open/close the doors without them catching on the rag top. Otherwise the top window edge catches in the recessed groove.
• Remove negative battery cable.
• Move steering column to lowest tilt setting.
• Remove (2) Phillips screws from underside of steering column plastic covering.
• Remove top and bottom covering and set aside. The top part comes off first, while the column is down. There are inside clips on the back end of the top/bottom covering that hold them together. If you push in at the back end (close to dash) on the bottom section you should be able to spring it free while lifting up on the top half. If not, carefully use a flat blade screwdriver from front to back to pop the clip. To get the bottom cover off, raise the steering column and it comes out much easier.
• The order of the next three steps can be *reversed* if there is not a lot of flexability to move the wiring harness around while the multi-function switch (MFS) mechanism is bolted in place.
• To disconnect the wiring harness, take a small flat screwdriver and push the red locking tab toward the engine, straight back. Do not lift on tab. It slides in and out.
• Disconnect wiring harness. Slowly. It should come out relatively easy. If problems, make sure red tab is pulled out as far as it easily slides.
• Remove (2) T20 Torx screws on top, close to steering wheel. Wiggle entire MFS off the posts holding the MFS so it can be moved around some.
• Remove (2) T10 Torx screws on right side by putting screwdriver through steering wheel spokes so the wiper switch can be disconnected.
• Pull wiper switch section out of your way to the right.
• Pull out old MFS.
• There was no dust cover on the 2005 model around the switch stalk.
• Transfer flasher module (not included with new part), on the side where the wiper switch was connected, by pulling it straight out/away from MFS. There are metal tabs on the back that can only be oriented one way to correctly insert it in the new MFS.
• Examine the two wires that come out the back of the MFS, snake around the edge (under hold-downs) and then up the middle of the switch stalk. Rearrange the wires to make it easier for them to move a little bit back and forth for when you move the switch stalk forward to engage high beams. I was concerned that having the wires tight would wear down the insulation and/or weaken the conductor. Don’t know what these two wires do but they do *not* control the fog lights.
• Place MFS back onto column, but not into proper position as you will need to install the wiper control.
• Install wiper switch with the (2) T10 Torx screws that were removed by once again reaching through the steering wheel spokes.
• Place MFS in the proper position on mounting posts.
• Install (2) T20 Torx screws into top mounting holes.
• Reconnect wiring harness. Carefully. Once the connector is fully pushed in, slide the red tab towards the steering wheel to lock the connection.
• Connect the negative battery terminal and test all functions of the switch stalk, 4 way flashers and wiper for proper operation. If any problems, *disconnect* the negative battery terminal and then check the wiring harness for being fully in place. Reconnect battery and try again.
• Install upper and lower plastic covers by moving the column down to put the top half in place and up to put the bottom half in place. Align and push the back ends (both sides) together to re-engage the locking tabs.
• Install (2) lower Phillips screws after aligning the front edge of the halves.
• Check that the column can still move up and down and that all switch functions on the MFS and wipers still work.
• Your done with only cleanup left.

Several other things to note.

• This part also goes under the number of “CBS-1210”. This number will fit a 2005 Cruiser.
• I suggest you pull the 15 AMP fuse for the fog lights from the inside fuse panel if you have any fog light problems in order to insure the lights don’t stay on and drain the battery. It is fuse #8 in a 2005 model. Check the back side of the fuse panel cover to ensure you remove the correct fuse.
• When the problem occurred and I had the fuse still in, headlights on and fog lights on (at least according to the switch position) the fog lights were not on.
• I also noticed that during this time, when I used the turn signals the display on the radio would blink in time with the turn signals.
• After I removed the fog light fuse, the radio display would very seldom blink when I used the turn signals. It always blinked when the fog light fuse was in place after the switch stalk problem started.
• I took apart the original factory installed MFS looking for anything glaring as to why the fog lights did not work. I found no broken parts inside the MFS. There is a plastic dowel down the middle of the stalk that works a leaver that pushes a metal contact up and down. The springs were good, the leaver worked, the stalk was not worn down or broken. There was oxide around one of the two contacts involved with the fog lights but I can’t tell if it was enough to stop electric from flowing. There was a lot of grease type lubricant on a lot of sliding parts inside the switch. Have to wonder about the electrical properties of the grease lubricant and if it was shorting things out or insulating contacts. Maybe it changes properties over time. Pure speculation on my part.

Anyway, my thanks to KG for posting his instructions and showing the way!

pdc
ericleatham likes this.
Reply With Quote
  #7 (permalink)  
Old 31 Dec 2009, 01:40 pm
THS_Cruiser03's Avatar
Regular Cruiser
 
Join Date: May 2008
Location: North Central IL, USA
Posts: 119
Default Re: Replace Multifunction Switch w/fog lamps

Hi Mopar Brethren! I know long time no hear from the THS_Cruiser....

Been lagging in completing upgrades on mine for a while now (work, life, wife, kids, money etc.). But now that winters here I have more time to work on her.

I like this post it solves some questions I had about installing aftermarket driving lights for my PT from this post:

Xenon HID vs. Factory Halogen - The test!

But also opens up a few other questions....

- Will the 2001 MF stalk part ( New Part# - 05073049AB) work on my 2003 Base PT? I think they are the same and wiring is similar enough but I don't know for sure.

- Also my DL kit is 55 watts for each bulb, can anyone confirm if the stock PT fog lights are also 55 watt?

- If not should I be using the same fuse rating as used for the low beam head lights?

Any replies or information would be greatly appreciated.

Thanks!

Tom

P.S. - For the record I've now logged over 80K on the THS_Cruiser, 30K with the engine mods and new cams - she's still running like a champ! Also now logged over 4k miles of night driving with the Xenon's and not 1 FLASH from opposing traffic...so I guess she's aimed well.
__________________

Base '03, Light Almond Pearl Metallic - Modified 2.4 na w/ported head, 10.4:1 compression ratio & Crane #10 camshafts - 4 speed - Energy Poly bushings - Napa ceramic pads & Ultra premium rotors - Rotora Stainless brake lines - Extreme Acc. Xenon HID 8k low & 6k high

Dark taupe & Ivory Interior, Factory CD w/Sirius Stratus 4, Power Acoustik 840w 4ch, Boss 200w 2ch w 10" bandpass sub, 2 sets Phoniex Gold Matched comp. speakers

Rolling stock: 16" SE A7w 225/50/16 Kuhmo Ecsta AST - One of the nicest Light Almond PT's you'll find
Reply With Quote
  #8 (permalink)  
Old 31 Dec 2009, 07:53 pm
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Default Re: Replace Multifunction Switch w/fog lamps

Tom..

For a 2005 model, the fog light bulbs are 9006's. Some searches around the web seem to indicate the 9006's are 55 watt bulbs.

There is also a comment at this link about bulbs more than 55 watts burning out the wiring harness.

Replacing the MFS is not much fun. Replacing a fried harness would be zero fun.

Good luck with your light replacements!

pdc
Reply With Quote
  #9 (permalink)  
Old 11 Jan 2010, 01:47 pm
THS_Cruiser03's Avatar
Regular Cruiser
 
Join Date: May 2008
Location: North Central IL, USA
Posts: 119
Post Re: Replace Multifunction Switch w/fog lamps

Hi PClayton, thanks for your reply. Thanks for confirming the stock fog lights are 55 watt.

Yes I agree with you. However I double checked my light kit and they are H3 bulbs at 55 watt rating (each) so I shouldn't have burned out harness issue.

Plus as a point of reference my xenons run 35 watts each (or 40 watts less than the draw of the stock Halogens) so I should be in good shape from an overall current draw perspective.

Is there a seperate fuse that runs the fog light circuit or is it on the same feed as the headlights?

In terms of replacing the base MF switch with the fog light version I think I'll just have the dealer do it (unless they want to charge me $400 labor) I need them to fix my trunk sensor anyway. Damn thing thinks the hatch is open all the time so my dome light is on all the time. Dealer already told me the sensor is probably bad. Though I bet it's just a mechanical issue that needs to be checked out - I don't open the hatch that much anyway (in my seven years of ownership probably less than 500 cycles which is NOTHING for a door life test BTW).

Tom
__________________

Base '03, Light Almond Pearl Metallic - Modified 2.4 na w/ported head, 10.4:1 compression ratio & Crane #10 camshafts - 4 speed - Energy Poly bushings - Napa ceramic pads & Ultra premium rotors - Rotora Stainless brake lines - Extreme Acc. Xenon HID 8k low & 6k high

Dark taupe & Ivory Interior, Factory CD w/Sirius Stratus 4, Power Acoustik 840w 4ch, Boss 200w 2ch w 10" bandpass sub, 2 sets Phoniex Gold Matched comp. speakers

Rolling stock: 16" SE A7w 225/50/16 Kuhmo Ecsta AST - One of the nicest Light Almond PT's you'll find
Reply With Quote
  #10 (permalink)  
Old 12 Jan 2010, 09:51 am
Fresh Cruiser
 
Join Date: May 2009
Posts: 5
Default Re: Replace Multifunction Switch w/fog lamps

As mentioned in the post, I found the fog lights to be on their own 15 AMP fuse on the inside fuse panel in position #8 for my 2005 model.

I recommend that you pull the inside fuse panel cover and look over the fuse layout for a fog light reference that is printed on the back side of the cover plate.

pdc
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multifunction switch gonzomania General PT Cruiser Discussions 18 26 Mar 2012 07:30 am
MultiFunction Switch Issues-HELP !!! jmack General PT Cruiser Discussions 10 26 Mar 2012 01:58 am
Error Codes skylight Tech & Performance Forum 7 28 Apr 2011 03:34 pm
Multifunction switch for postage Shini Quiet Classifieds: For Sale/Trade 0 23 Sep 2004 10:29 am
Multifunction switch gonzomania General PT Cruiser Discussions 5 23 Feb 2004 04:35 pm


All times are GMT -5. The time now is 06:54 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors