PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
'04 PT Turbo/GT stalling problems!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Sep 2007, 09:13 pm
Fresh Cruiser
 
Join Date: Sep 2007
Posts: 3
Default '04 PT Turbo/GT stalling problems!

Good evening all!

I drove my 04 PT with 42k miles around all day today with no problems. This evening I backed it out of the garage and stepped on the gas and it stalled.

At idle the car sounds great and idles at the normal 1k.
At all times it smells like burning gas coming out the exhaust.

If you give the car half gas (what i would consider normal to start moving) the RPM will go down to 0 and the car will stall

If you give the car a tiny amount of gas the RPM will drop a little and the car will drive forward.
If you continue to only give it light gas you can get the speed up to normal driving speed and you still smell the burning gas.
If you are driving normal speed and press the gas down to accererate at a normal amount you hear some crazy rattling up at the engine. Sounds like rocks in a can.

If you put the car in reverse everything seems perfectly normal.

Temperature is in the normal range.

I did fill up earlier on today, could I have gotten some bad gas? Should i run it till it runs out of gas and try putting new gas in the vehicle or is that a waste of time?

Thanks!
Reply With Quote
  #2 (permalink)  
Old 01 Oct 2007, 07:53 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: '04 PT Turbo/GT stalling problems!

Quote:
Originally Posted by pcm2a View Post
If you are driving normal speed and press the gas down to accererate at a normal amount you hear some crazy rattling up at the engine. Sounds like rocks in a can.
Welcome.
What you describe is a classic description of pinging or detonation. It is bad for your engine.
Did you put in regular? Try some octane booster if tank is full.
Sounds like you have low-octane gas and the knock sensor is trying to retard spark so much the car stalls.
At 42,000 miles, I hope you have replaced the plugs and wires - if not, that'd contribute to your problems.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalling, rough idle, running "hard", hesitation LiLOrion Tech & Performance Forum 36 21 May 2013 12:43 pm
'02 Cruiser with lots of problems :( slpknt2886 Tech & Performance Forum 4 07 Aug 2007 02:17 pm
So much problems before inspection Ctown General PT Cruiser Discussions 3 12 Apr 2005 07:45 pm
Dealer upgrades, any problems??? knowyourturbo Stage Turbo Kits 0 14 Sep 2003 03:21 pm
Problems Oddcouple General PT Cruiser Discussions 1 17 Nov 2002 01:58 pm


All times are GMT -5. The time now is 10:23 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors