PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
My Pt Squeaks!!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 27 Nov 2007, 03:41 pm
Fresh Cruiser
 
Join Date: Nov 2007
Posts: 1
Unhappy My Pt Squeaks!!

Hello: I am new to this forum. I have a 2002 PT that now has some terrible squeaks in the front end. Not the brakes. The suspension.
Chrysler dealer said they want to change everything!
Has anyone else had a similar problem?
There has to be a cheaper & easier way.
Thanks for any help.
Reply With Quote
  #2 (permalink)  
Old 27 Nov 2007, 04:39 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 952
Default Re: My Pt Squeaks!!

I had same problem,,CHRYSLER KNOWS about this issue,,lower control arm bushings are weak & defective,,with some hounding they paid minus a $100.00 deductible,, ** It should be a recall** or maybe covered for life like the "lifetime warranty!!" '(03 PT Touring which I bought new)
Reply With Quote
  #3 (permalink)  
Old 28 Nov 2007, 09:07 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: My Pt Squeaks!!

Suspect MJB is correct. DO NOT HAVE DEALER DO IT. They will sell you new control arms, when all that is wrong is the rubber bushings. Ask around and find a local mechanic. They can replace the bushings for far cheaper - but it's a messy job, so ask the mechanic nicely...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 28 Nov 2007, 07:09 pm
mjb457's Avatar
Fanatic Cruiser
 
Join Date: Oct 2005
Location: Bucks County,PA. USA
Posts: 952
Default Re: My Pt Squeaks!!

CALL CHRYSLER MAKE THEM PAY!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1
Reply With Quote
  #5 (permalink)  
Old 28 Nov 2007, 07:44 pm
Veteran Cruiser
 
Join Date: Mar 2003
Location: Oregon.
Posts: 3,521
Default Re: My Pt Squeaks!!

The squeaks that made my wife's '04 PT sound fifty years old was the front sway bar end links.
__________________
\'05 Stone White SRT4

\'04 Graphite PT Automatic
Reply With Quote
  #6 (permalink)  
Old 01 Dec 2007, 08:19 am
Regular Cruiser
 
Join Date: Jun 2007
Location: Wellington, Florida
Posts: 191
Default Re: My Pt Squeaks!!

I got 75,000 miles on my '05. The front end is just starting to make kind of a rubbing sound not squeek when the suspension flexes. Not terribly noticable at this point.
__________________
2005 GT Cruiser, Cool Vanilla, Automatic, Borla Dual Exhausts, K&N, Navigation and U Connect.

2001 Corvette Convertable, Navy Blue Metalic, Z51, 3:15 with 4" inch quad Borla Stinger Exhausts X Pipe and K&N Filter.
Reply With Quote
  #7 (permalink)  
Old 01 Dec 2007, 10:20 am
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default Re: My Pt Squeaks!!

mine pt and wifes pt also have gone thru this both cars were covered at the time one car lower control arms and other car with sway bar bushings
Reply With Quote
  #8 (permalink)  
Old 04 Dec 2007, 08:53 am
Fresh Cruiser
 
Join Date: Nov 2007
Posts: 30
Default Re: My Pt Squeaks!!

I bought a brand new '06 and had the same problem at only 32k miles!! Fortunately it was still covered under the 3/36 warranty! They had to replace both front driver and passenger side lower control arm bushings AND on the driver side about 3 weeks later the sway bar linkage broke so the sway bar was hanging down. Had to have it towed back to the dealership. They blamed that on a defective linkage part and replaced it.

I'm crossing my fingers that the new bushings last and nothing else goes wrong because we're now only about 500 miles left on the bumper/bumper. From here on out it'll be a battle with the service dept and $$$ out of my pocket.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:38 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors