PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
The engine temperature Issue.

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Dec 2007, 06:34 pm
Fresh Cruiser
 
Join Date: Dec 2007
Location: MI
Posts: 14
Default The engine temperature Issue.

HI.

I have 02 PT which is 110k on it. The heater do not blow the warm air to inside. When the car was stop, the warm wind comes out. However the car makes always cold air while the car was driving. Here is Michigan. The outside temp. is usually F20. The engine temp gauge stays cold position while the car is driving on the highway. It is horrible. Can't I drive in the winter season? What's wrong?

Thanks.
Reply With Quote
  #2 (permalink)  
Old 25 Dec 2007, 08:55 pm
soonercruiser's Avatar
Obsessed Cruiser
 
Join Date: Jun 2007
Location: Oklahoma City
Posts: 7,651
Default Re: The engine temperature Issue.

That sounds like the thermostat is stuck "open".
A PT with 110K on it needs some TLC - service! When was the coolant system flushed last?
Reply With Quote
  #3 (permalink)  
Old 26 Dec 2007, 05:42 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: The engine temperature Issue.

Agree. Temp gauge should come up to 1/2 way - if it doesn't thermostat needs replacing.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 27 Dec 2007, 12:23 am
Cool Cruiser
 
Join Date: Dec 2007
Posts: 369
Default Re: The engine temperature Issue.

agree with sooner and quick. if temp reads normal, either your heater core is clogged or airlocked, the flap door inside the heaterbox isnt working, or it could be as simple as the cabin air intake in the cowl is clogged with debris.
__________________
06 Touring Edition NA/Auto. Airaid intake, Magnaflow Stainless cat-back exhaust, Taylor Thundervolt plug wires, rear lowered 1.75" with H&R Springs.
Yep, buying parts I cant afford with money I dont have to impress people I dont like anyways.
Reply With Quote
  #5 (permalink)  
Old 28 Dec 2007, 05:17 pm
Fresh Cruiser
 
Join Date: Nov 2007
Posts: 7
Default Re: The engine temperature Issue.

Another vote for the thermostat.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Codes skylight Tech & Performance Forum 7 28 Apr 2011 03:34 pm
Error Code List skylight General Turbo Discussions 6 07 Apr 2007 02:11 pm
"Mysterious" turbo engine noise...??? Gary04GT Turbo Performance 76 21 Aug 2006 08:28 am
Review: $2200 for a NA replacement engine PT Ctown General PT Cruiser Discussions 8 24 Jul 2006 01:08 pm
Air Intake Temp using stock components Dalite Turbo Performance 16 28 May 2003 05:35 pm


All times are GMT -5. The time now is 04:47 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors