PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
code p0340

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 29 Feb 2008, 01:47 pm
Fresh Cruiser
 
Join Date: Sep 2007
Posts: 24
Default code p0340

Here is the story. The other day we left in the pt and it took a little bit for it to start. Then yesterday the i went to leave for lunch and the car started to shake as i was driving and then shut off. I restarted it and the check engine light was on and the car was idling funny. Threw the code p0340, cam posistioning sensor. I parked it and then drove home later from work without and problems but the engine light was on. Car was fine last night and today and then finally the light shut off. The code is still there but the light is off. Does the sensor need changing or was it something else? Any input welcome. Thanks
Reply With Quote
  #2 (permalink)  
Old 29 Feb 2008, 03:01 pm
Fresh Cruiser
 
Join Date: Sep 2007
Posts: 24
Default Re: code p0340

Okay it did it again today so i just bought a sensor. Hopefully this fixes it.
Reply With Quote
  #3 (permalink)  
Old 04 Mar 2008, 06:34 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: code p0340

Fairly common. You get it replaced?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #4 (permalink)  
Old 04 Mar 2008, 11:21 pm
Fresh Cruiser
 
Join Date: Sep 2007
Posts: 24
Default Re: code p0340

Yes i replaced it the other day and so far so good. Thank God.
Reply With Quote
  #5 (permalink)  
Old 20 Oct 2008, 09:12 pm
Rodville's Avatar
Fresh Cruiser
 
Join Date: May 2008
Location: Orlando
Posts: 29
Default Re: code p0340

Sorry to hijack the tread but My PT is throwing this code but is running fine. I did a search and all the threads showing this code have said the car is running rough. Mine's not. Help please. It's an 03 if that helps.
Reply With Quote
  #6 (permalink)  
Old 21 Oct 2008, 06:12 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: code p0340

Rod,

If you have the code and have seen the threads you know where the sensor is. Trace the wires and make sure they are connected. Even pull off the connection to the sensor and put it back on again to make sure it's a good tight fit. If your not having problems associated with that sensor, just keep an eye out. Disconnect the negative battery terminal for a few minutes to get rid of the stored codes.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mopar radio security code. Ian-PT-GT Sound and Security Forum 15 15 May 2016 08:40 pm
Engine Won't Start -- Code P0129 nimblemotors Tech & Performance Forum 2 29 Apr 2016 09:45 pm
Check Engine Light came on - code 1188? coolvirus General Turbo Discussions 38 25 May 2011 09:01 am
Need diag. code info RIvey Tech & Performance Forum 1 01 Oct 2005 12:05 pm
BOV & P0443 code Topless in Cali General Turbo Discussions 5 15 Aug 2005 06:06 pm


All times are GMT -5. The time now is 11:57 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors