PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
babsaberry

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Apr 2008, 11:58 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 1
Unhappy babsaberry

Does anyone else have a problem with the horn not working, or hitting the horn and the radio coming off or on.

Also my rear lights keep going out. HELPPPPPP
Reply With Quote
  #2 (permalink)  
Old 06 Apr 2008, 07:23 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: babsaberry

babsaberry, Welcome to the Forum, . You haven't given us much info, like Turbo or NA, year, bought new or used etc. You have to fill out as much info as you can.

I have a 2006 and the horn did not work EXCEPT at a "sweet spot", I kept bugging the service dept at my dealer. I informed NTSB (?) of the problem. Finally Chrysler came out with a fix. They had to install a new housing behind the steering wheel and now all works fine.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 06 Apr 2008, 02:44 pm
Fanatic Cruiser
 
Join Date: Jun 2003
Location: Greensboro, North Carolina, USA.
Posts: 884
Default Re: babsaberry

The horn on my '02 quit working. Dealer said entire airbag assembly in the steering wheel had to be replaced, $600. Had a local garage look at it. They said some sort of pins in the steering wheel had worn. Whatever they did made the horn work. I have to press directly on the little horn emblem, but at least it works. And they only charged me $49.
__________________
Reply With Quote
  #4 (permalink)  
Old 08 Apr 2008, 04:21 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default Re: babsaberry

600 !! wow just because the horn stopped working thats nuts !! why would the other stuff have to be replaced ??
Reply With Quote
  #5 (permalink)  
Old 08 Apr 2008, 09:29 pm
Fanatic Cruiser
 
Join Date: Jun 2003
Location: Greensboro, North Carolina, USA.
Posts: 884
Default Re: babsaberry

Dealer "claims" its all one big part and that there was no clock spring inside the steering wheel.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:04 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors