PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Engine problem

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 May 2008, 11:27 am
Fresh Cruiser
 
Join Date: May 2007
Posts: 3
Default Engine problem

I have a 2005 PT Cruiser 2.4l and it has been giving me problems from time to time.

When I drive, I may experience a few minutes of where the car loses its pep and starts to stutter. I can be driving 55 and the girl will start to "die" out.

I can push the gas peddle down and it will just hang around 40mph until, after a few seconds, it kicks in.

I took it in to the dealer and he said it needed new plugs and wires (60,000 miles on it). I didn't believe that to be the problem but I had them change it and still didn't fix it.

Does anyone have any ideas as to what this may be?

Thanks
Reply With Quote
  #2 (permalink)  
Old 05 May 2008, 05:24 pm
Regular Cruiser
 
Join Date: Jun 2007
Location: Wellington, Florida
Posts: 191
Default Re: Engine problem

You need to change your spark plug wires and maybe you plugs as well. Same thing happened to me.
__________________
2005 GT Cruiser, Cool Vanilla, Automatic, Borla Dual Exhausts, K&N, Navigation and U Connect.

2001 Corvette Convertable, Navy Blue Metalic, Z51, 3:15 with 4" inch quad Borla Stinger Exhausts X Pipe and K&N Filter.
Reply With Quote
  #3 (permalink)  
Old 05 May 2008, 05:42 pm
Young Cruiser
 
Join Date: Mar 2008
Posts: 83
Default Re: Engine problem

Have you had the computer checked for any codes
Reply With Quote
  #4 (permalink)  
Old 05 May 2008, 08:01 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Engine problem

Quote:
Originally Posted by bados View Post
You need to change your spark plug wires and maybe you plugs as well. Same thing happened to me.
He said he had them changed.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 05 May 2008, 08:03 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Engine problem

Quote:
Originally Posted by GoldenDomer View Post
I took it in to the dealer and he said it needed new plugs and wires (60,000 miles on it). I didn't believe that to be the problem but I had them change it and still didn't fix it.

Does anyone have any ideas as to what this may be?

Thanks
Go back to the dealer and complain. You did what they recommended, and still have the problem.
Reply With Quote
  #6 (permalink)  
Old 06 May 2008, 06:09 am
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default Re: Engine problem

have the fuel injectors cleaned also ?? just a thought
Reply With Quote
  #7 (permalink)  
Old 18 May 2008, 12:02 am
Cool Cruiser
 
Join Date: Mar 2008
Location: Orlando Florida
Posts: 414
Send a message via Yahoo to partyd
Default Re: Engine problem

did you find the problem with your engine ?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine problem BORICUA Tech & Performance Forum 50 23 Jun 2012 03:40 pm
Help! 2003 Turbo Engine problem! henroid2 General Turbo Discussions 8 03 Mar 2008 04:13 pm
Review: $2200 for a NA replacement engine PT Ctown General PT Cruiser Discussions 8 24 Jul 2006 01:08 pm
Update on my engine light problem jsp70 General Turbo Discussions 1 11 Aug 2004 08:15 am
Engine problem??? CHROMEDCRUISER Tech & Performance Forum 12 07 May 2004 01:35 pm


All times are GMT -5. The time now is 08:25 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors