PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
AC not working on 06 PT

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06 Jul 2008, 10:48 pm
Fresh Cruiser
 
Join Date: Jul 2008
Posts: 4
Default AC not working on 06 PT

I took my car in to the shop and was told that they found 2 leaks which they repaired and charged me almost $200.00. They told me I need a new fan assembly, however they don't do electrical. They said I'd likely need to rev the engine at stops to keep the ac blowing cold. It blew cold off and on for a day or two, and it didn't matter if I was stopped or driving 65 on the freeway. The cold would fad in and out, and now it's not working. I'm in Phoenix, so our temps are 110 plus. The car isn't overheating. Any ideas?
Reply With Quote
  #2 (permalink)  
Old 07 Jul 2008, 06:38 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: AC not working on 06 PT

Karleton, welcome to the forum.

If they told you the fan motor is burnt out there's not much else you can do but replace it. Hopefully they know what they were doing and their analysis was correct. It's a common part on the PT that fails. I've replaced it on mine. Rather than go over the whole procedure, here's a link to a thread that talks about it. There's loads more threads if you care to do a search on "fan".

Fan not coming on
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 07 Jul 2008, 03:04 pm
Obsessed Cruiser
 
Join Date: Dec 2002
Posts: 6,787
Default Re: AC not working on 06 PT

isnt the car still covered under warrenty ??
Reply With Quote
  #4 (permalink)  
Old 07 Jul 2008, 09:54 pm
Fresh Cruiser
 
Join Date: Jul 2008
Posts: 4
Default Re: AC not working on 06 PT

I don't believe so as it has 60,000 miles
Reply With Quote
  #5 (permalink)  
Old 08 Jul 2008, 06:29 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: AC not working on 06 PT

I thought most PT's in the last couple years had the 7 years, 70,000 mile warranty.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 08 Jul 2008, 08:01 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: AC not working on 06 PT

They did until 2006 (I believe) and then it went to 3 years-30,000 miles unless covered under government EPA regulations. ie: emission systems. Of course now it is lifetime warranty power train.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #7 (permalink)  
Old 08 Jul 2008, 10:53 pm
Fresh Cruiser
 
Join Date: Jul 2008
Posts: 4
Default Re: AC not working on 06 PT

Anyone know for sure about the warranty on a 06, and if so would an AC problem be covered? I don't have an owners manual, thus I thought I saw somewhere that the warranty was 36,000/3yr. Hope I'm wrong.
Reply With Quote
  #8 (permalink)  
Old 09 Jul 2008, 07:12 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: AC not working on 06 PT

I would take it to a dealer and have them check it out. They will be able to tell you if it would be covered or not.

I have always had Chrysler Extended Warranty so haven't had to pay anything other than my deductable. Good Luck.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ciggy lighter & Power outlet not working -all fuses fine. swisstony10 Tech & Performance Forum 19 09 May 2016 02:59 pm
A/C not working dexadel Tech & Performance Forum 98 03 Oct 2015 07:36 am
my OEM remote stop working like before??? Ctown Sound and Security Forum 4 30 Jul 2006 01:14 am
Turn Signals Not Working Indynick General PT Cruiser Discussions 9 15 Sep 2004 02:25 pm
Back up lights not working cheeseball Tech & Performance Forum 2 15 Apr 2003 01:43 pm


All times are GMT -5. The time now is 02:47 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors