PT Cruiser Forum  
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

No turn signals, wipers, washers for 2006 pt

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Dec 2008, 04:36 pm
Fresh Cruiser
 
Join Date: Dec 2008
Posts: 3
Default No turn signals, wipers, washers for 2006 pt

The wiper blades on my wife's 2006 PT Cruiser were not working this morning. I took a look and noticed that also the washer fluid (front & back), wipers (front & back) and turn signals were not working. The cruise control button did seem to work though.

I've been scouring the internet for help on this problem, and it seems it used to be fuse #15 that could be replaced to solve this problem. Unfortunately, it seems as though the 2006 model put all the fuses in the intregated power module, and it's very hard to find the problem fuse (if that is the problem) from the owner's manual as none are labelled for the wipers/turn signals. Can anyone help? I took the car to AutoZone (closest car place) and we looked at fuse #31 (Headlamp Washer Relay Control) and one other (I can't recall the #) but neither were blown.

I appreciate any help I can get!
Reply With Quote
  #2 (permalink)  
Old 08 Dec 2008, 08:46 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: NW NJ
Posts: 12,242
Default Re: No turn signals, wipers, washers for 2006 pt

There aren't THAT many fuses.
Take each out and either replace it with a new one (they aren't that expensive) or hold it up to a light to see if it's blown.
There are also fuses underhood - driver's side, behind/above air cleaner.
__________________
'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 08 Dec 2008, 09:13 pm
Fresh Cruiser
 
Join Date: Dec 2008
Posts: 3
Default Re: No turn signals, wipers, washers for 2006 pt

There are 37 fuses listed in the owner's manual. There actually are no fuses inside the car in the 2006 model (at least, not shown in the manual) and they are all under the hood. I believe this was changed going from 2005 to 2006. We took the car to Midas and they believe there is a problem within the steering column that requires dealer servicing. I will update with the solution (hopefully) in case anyone else ever has this problem.
Reply With Quote
  #4 (permalink)  
Old 08 Dec 2008, 09:53 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,024
Default Re: No turn signals, wipers, washers for 2006 pt

Midas may be in the right ares, it may be the multifunction switch as it is very easily burned out.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 13 Dec 2008, 09:55 pm
Fresh Cruiser
 
Join Date: Dec 2008
Posts: 3
Default Re: No turn signals, wipers, washers for 2006 pt

This is just to confirm that it was indeed the multifunction switch and the repair at the dealer cost a little more than $200 after taxes. Thanks for the help.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signals AlexJB Exterior Accessories Forum 6 12 May 2008 09:12 pm
Rear turn signals? thegoldpt Non-PT Discussions 5 13 Jan 2006 11:22 am
PT turn signals (or lack of) dgranros Tech & Performance Forum 5 18 Mar 2005 11:06 am
Turn Signals Not Working Indynick General PT Cruiser Discussions 9 15 Sep 2004 03:25 pm
Intermittent Turn Signals Puck Interior Accessories Forum 2 11 Aug 2003 08:47 pm


All times are GMT -5. The time now is 05:40 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors