PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Mopar Cruise Control problems...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05 Apr 2009, 06:47 pm
Fresh Cruiser
 
Join Date: Apr 2009
Location: Palm Harbor, FL
Posts: 1
Angry Mopar Cruise Control problems...

Well my father bought this kit, and i spent most of my day in the sweltering sun installing this. Then after double checking everything, we started the car, and took it for a spin. Then we realized the cruise controll didnt work even at a speed of 35. Then when we went to go double check all of our wires, the little spinning thing behind the steering wheel came off and the ribbon cable came out, so got that to go back in finally (not sure if its right, anyone who has some instructions for that please email them to me). Then started it up and after backing out the driveway the airbag light came on.

To just let everyone know, when we first took it out and realized it didnt work, we did not even see the word cruise come up on the center display like it is supposed to? Any and all help would be nice because the paperwork mopar sent did not have any words or help for us. Please, all i want to do is get this fixed asap.

If anyone has a parts list of the steering column parts like from a haynes that would be nice because i have to reorder the piece that sites behind the steering wheel *one of the cheap plastic tabs broke, and even superglue wont hold it.

Thanks, Porkchop
Reply With Quote
  #2 (permalink)  
Old 06 Apr 2009, 06:11 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Mopar Cruise Control problems...

Here's what I have from Haynes....





I have a parts catalog but not sure which part (with clips) your talking about. If it's the cover for the Air Bag Module, then the part number is: 4664 253AC That has some big tabs on it that you might be calling "clips".

One more thing. I seem to remember someone else putting in a Mopar cruise control and it seems (if I remember right) that they had to take it back to the dealer to have the cruise programmed into the computer. Maybe that's why the "cruise" light won't come on.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.

Last edited by CREWZIN; 06 Apr 2009 at 06:15 am.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light came on - code 1188? coolvirus General Turbo Discussions 38 25 May 2011 09:01 am
part numbers Punch General Turbo Discussions 8 19 Sep 2009 08:44 pm
2001 pt cruise control problems charlieborg General PT Cruiser Discussions 4 23 Nov 2008 11:14 pm
MOPAR CRUISE CONTROL KIT Poppapug Tech & Performance Forum 8 06 Oct 2008 06:29 pm
cruise control problems charlieborg General PT Cruiser Discussions 3 18 Jul 2008 12:24 pm


All times are GMT -5. The time now is 04:04 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors