PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
P0339 check engine

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04 May 2009, 09:43 am
Fresh Cruiser
 
Join Date: Feb 2008
Posts: 6
Question P0339 check engine

Hello everyone.

I have 2003 PT Cruiser TE. My wife told me she took the car for a bit Saturday and the check engine light came on.

I used my code scanner and it threw me a P0339 - "Crankshaft Position Sensor 'A' Circuit Intermittent". No other codes. I asked her how the car was running lately and if she noticed any problems, she said it drives fine.

I figure for the light to come on the fault has to have happened more than once and just my luck, the car has to pass inspection this month.

Any ideas on this problem? Thanks for your help.
Reply With Quote
  #2 (permalink)  
Old 04 May 2009, 10:12 am
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: P0339 check engine

Try taking the negative battery cable off for at least 5 minutes to reset the codes to see if it stays off.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 04 May 2009, 12:20 pm
Fresh Cruiser
 
Join Date: Feb 2008
Posts: 6
Default Re: P0339 check engine

Quote:
Originally Posted by Hooligan View Post
Try taking the negative battery cable off for at least 5 minutes to reset the codes to see if it stays off.
I will clear it with my scanner and see if it resurfaces.

It will fail inspection with the code stored anyway.
Reply With Quote
  #4 (permalink)  
Old 04 May 2009, 04:12 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: P0339 check engine

That's why I suggested removing the negative cable, to clear the codes.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #5 (permalink)  
Old 04 May 2009, 06:41 pm
Fresh Cruiser
 
Join Date: Feb 2008
Posts: 6
Default Re: P0339 check engine

Quote:
Originally Posted by Hooligan View Post
That's why I suggested removing the negative cable, to clear the codes.
How easy is it to replace the crankshaft sensor on my year model? Just curious.
Reply With Quote
  #6 (permalink)  
Old 04 May 2009, 06:56 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: P0339 check engine

Quote:
Originally Posted by ruscorp View Post
How easy is it to replace the crankshaft sensor on my year model? Just curious.
If they haven't changed it, doesn't look bad at all.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #7 (permalink)  
Old 12 Feb 2010, 09:57 am
Fresh Cruiser
 
Join Date: Feb 2008
Posts: 6
Default Re: P0339 check engine

I just wanted to post an update to this thread.

The problem has progressively gotten worse even after the crankshaft sensor wasd replaced and now my mechanic is talking about replacing the on-board computer.
Reply With Quote
  #8 (permalink)  
Old 12 Feb 2010, 10:51 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: P0339 check engine

Quote:
Originally Posted by ruscorp View Post
I just wanted to post an update to this thread.

The problem has progressively gotten worse even after the crankshaft sensor wasd replaced and now my mechanic is talking about replacing the on-board computer.
Was the sensor from a dealer? There have been many reports of bad aftermarket sensors. May give that a try first. Computer is expensive.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #9 (permalink)  
Old 12 Feb 2010, 11:16 am
Fresh Cruiser
 
Join Date: Feb 2008
Posts: 6
Default Re: P0339 check engine

Quote:
Originally Posted by quicksilverdon View Post
Was the sensor from a dealer? There have been many reports of bad aftermarket sensors. May give that a try first. Computer is expensive.
That is exactly why I am bulking here. Replace computer = "I give up", in my head.

He didn't try to replace the cam sensor or check the timing belt. (Maybe it skipped a tooth.)

I thought about the aftermarket sensor, I will suggest that to him when I bring it back.

I don't really have much choice but to fix the problem. The car is financed.
Reply With Quote
  #10 (permalink)  
Old 12 Feb 2010, 01:53 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: P0339 check engine

How many miles? Crank & cam sensor codes do go with timing belt - if 90,000+ could be timing belt....
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Check Engine" idiot light on AGAIN tezz General Turbo Discussions 17 17 Sep 2015 11:54 am
Check engine light just came on! lajag24t Tech & Performance Forum 22 13 Aug 2009 05:22 pm
Check engine light, skipping ab1 Tech & Performance Forum 2 02 Aug 2008 11:13 pm
06 turbo check engine light 06SilverTurbo Tech & Performance Forum 23 21 May 2008 02:20 pm
Check engine oil light question AaronR General PT Cruiser Discussions 5 28 Aug 2004 03:18 am


All times are GMT -5. The time now is 03:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors