PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Horn does not work

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30 Jun 2009, 09:10 am
blownbayou's Avatar
Fresh Cruiser
 
Join Date: Oct 2007
Posts: 13
Default Horn does not work

Did some searching and came up with nothing on this.......My wife's PT (2002) has a horn problem. It will not work via the switch on the steering wheel. It sounds when you lock it but nothing when you hit the switch. I looked at it breifly this morning and cannot figure out how to pop the cover off without breaking something. How do you go about taking the cover off the steering wheel to get to the switch??? I also read on here about a wire harness that controls the horn, airbag and cruise but I figure this would throw a CEL if it was bad.

Please help me on this.....Inspection is due tomorrow!!!!

Thanks
__________________
2000 White Lightning 6#lower, 90MM MAF, RWTD tune, CAI, FTVB, !pcv
2002 PT Cruiser STOCK FOR LIFE
2007 Nissan Titan 4x4 XE CC with mods
Quote:
Originally posted by mato13
YAH, BLOWNBAYOU! baddst sound'n L ive heard yet!
http://media.putfile.com/Lightning-Exhaust


Reply With Quote
  #2 (permalink)  
Old 30 Jun 2009, 09:34 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Horn does not work

I haven't taken it off myself but maybe this will help you.

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 30 Jun 2009, 10:13 am
blownbayou's Avatar
Fresh Cruiser
 
Join Date: Oct 2007
Posts: 13
Default Re: Horn does not work

Quote:
Originally Posted by CREWZIN View Post
I haven't taken it off myself but maybe this will help you.


That is helpful.....Thanks!!!!

I have read there are two clips on the back of the steering wheel or column.....Guess I am am going to disconnect the battery, push brake (discharge any elec juice) and look for these clips. If that is not sucessful, an old fashion horn button might be the answer. I think it would look good in the Cruiser being that the Cruiser was modeled after 40's to 50's style cars anyways.

Keep coming with the help!!!

Thanks
__________________
2000 White Lightning 6#lower, 90MM MAF, RWTD tune, CAI, FTVB, !pcv
2002 PT Cruiser STOCK FOR LIFE
2007 Nissan Titan 4x4 XE CC with mods
Quote:
Originally posted by mato13
YAH, BLOWNBAYOU! baddst sound'n L ive heard yet!
http://media.putfile.com/Lightning-Exhaust


Reply With Quote
  #4 (permalink)  
Old 30 Jun 2009, 12:04 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Horn does not work

Some tips-
Where the hood release cable comes thru the firewall is a good place to run wires.
The surround around the steering column comes apart with 2 phillips screws and unsnaps.
When you look, you'll see plenty of room - I added a push-button switch in there (drilled a small hole in the plastic) and have my Aoogah horn on the steering column right by the wheel.
Use the push-button switch to control a relay so all the horn current doesn't come thru the switch.
Hope that helps.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #5 (permalink)  
Old 30 Jun 2009, 12:18 pm
blownbayou's Avatar
Fresh Cruiser
 
Join Date: Oct 2007
Posts: 13
Default Re: Horn does not work

If I cannot fix the horn switch, I am going to tie into the wire going to the horn relay and run it to one side of the push button and run power to the other side of the push button. Should work out good. Thanks for the tips!!!!
__________________
2000 White Lightning 6#lower, 90MM MAF, RWTD tune, CAI, FTVB, !pcv
2002 PT Cruiser STOCK FOR LIFE
2007 Nissan Titan 4x4 XE CC with mods
Quote:
Originally posted by mato13
YAH, BLOWNBAYOU! baddst sound'n L ive heard yet!
http://media.putfile.com/Lightning-Exhaust


Reply With Quote
  #6 (permalink)  
Old 01 Jul 2009, 07:48 am
blownbayou's Avatar
Fresh Cruiser
 
Join Date: Oct 2007
Posts: 13
Default Re: Horn does not work

update.......Very easy getting the bag off. Easier than I expected. After removing the top and bottom steering column cover, I pulled the clips back on the two notches (thanks for the illustration) and it popped off. I messed with the wire coming from the switch and ultimately wrapped it around one of the bolts on the air bag cover. Works perfectly now..... Kind of a shade tree fix, but inspection is due today and no Dealerships (parts) were open that late yesterday.

Thanks again for the illustration!!!! That was key for me removing the cover and finding the horn switch connector.

Later
__________________
2000 White Lightning 6#lower, 90MM MAF, RWTD tune, CAI, FTVB, !pcv
2002 PT Cruiser STOCK FOR LIFE
2007 Nissan Titan 4x4 XE CC with mods
Quote:
Originally posted by mato13
YAH, BLOWNBAYOU! baddst sound'n L ive heard yet!
http://media.putfile.com/Lightning-Exhaust


Reply With Quote
  #7 (permalink)  
Old 01 Jul 2009, 02:08 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Horn does not work

No Problem. Glad it worked out for you.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn going dead turbomangt General Turbo Discussions 5 20 Jun 2009 04:35 pm
HELP - horn honks all the time PatJ General PT Cruiser Discussions 4 25 Jan 2009 09:10 am
Horn and headlights problem ducerman Tech & Performance Forum 6 18 Dec 2007 10:24 pm
2nd horn addition for '03 GT JohnM General PT Cruiser Discussions 13 31 Jul 2003 10:50 pm


All times are GMT -5. The time now is 03:43 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors