PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
P0884 '03 Cruiser

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Jul 2009, 03:16 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Prince Frederick, MD
Posts: 9
Default P0884 '03 Cruiser

Hello All,

I have a little bit of mechanical knowledge and tools to do most of the basic repairs to the cruiser. I have an '03 Touring cruiser with 74K miles on it. I have ran into a issue a few days ago when the vehicle would not go above 40 mph. I was not far from home and was able to turn around and park it. I used my Solus scan tool for codes even though the check engine light was not on. I recived the code p0884 TCM Power Input Signal Intermittent. Following the 2k page manual from Candyman (thank you) I pulled the front tire to get to the TCM to meter an open or a short. When I removed the tire there was no TCM mounted to the frame rail. I do not know what this could mean other than the TCM is a part of the PCM and if so how could I tell if the PCM is bad or my transmission is going?
I did the solenoid test and they all fire and there was not a high amount of shavings in the transmission pan. I replaced the filter with a new one now.Currently I am at a loss and I keep getting snippets to let go of the cruiser and get like an HHR. I may have to cut my losses soon because I cannot he up front cost of a new transmission. The nearest dealer is 38 miles away and it may have to be towed there. I do not want to run the risk of doing any further damage to the vehicle, plus only being able to go 40 mph when the speed limit is 50-65 would be brutal.
I do not want to see the cruiser go because it was my first vehicle that I purchased brand new off the lot. Thank you all for your help in advance.


BW

Last edited by BWTL; 15 Jul 2009 at 09:16 am. Reason: grammar and clarification
Reply With Quote
  #2 (permalink)  
Old 16 Jul 2009, 07:12 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: P0884 '03 Cruiser

Welcome and sorry to hear.
Any good mechanics closer?
Sure sounds like "limp mode", but strange engine light isn't on.
I read Crewzin's post on other thread, and I have read that strange things happen when battery dies - worth checking before you dump a ton of money.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 17 Jul 2009, 09:34 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Prince Frederick, MD
Posts: 9
Default Re: P0884 '03 Cruiser

Hooked everything back up and installed a new battery. Got it moving down the driveway (1500ft) turned onto the main road and it still did not go past 20mph. the engine shutdown as I was going up a steep hill. (trip one I guess). Coming back to the house I put it in neutral and cycled the key to the off position. This was about 5 seconds. Not much traffic goes down the road so it was safe. Cycled key on/run (Trip 2). Still did go above 20 mph. Repeated neutral/cycle trick once I hit the driveway but did not attempt to exceed 20 mph, fear off sudden engagement and smashing into a tree. Parked, cycled the PRNDL lever leaving it in each gear for 1 minute, cycled to park, let it idle for 5 minutes, no codes, turned it off and went inside to make a few calls and repost my results.
End result no dice on new battery. Someone mentioned timing belt, but honestly do not see the relationship between gear shifting and cam/cank position.
Thanks again you all for helping me. I will continue on with this endeavor.
Reply With Quote
  #4 (permalink)  
Old 17 Jul 2009, 10:07 pm
Sharkstooth's Avatar
Young Cruiser
 
Join Date: Jul 2009
Location: Boca Raton,Fl
Posts: 87
Default Re: P0884 '03 Cruiser

Have you checked the catalitic converter? They can break apart inside and clogg the exhaust and cause no power and this would not through a code,its worth checking.Good luck.
Reply With Quote
  #5 (permalink)  
Old 23 Jul 2009, 01:40 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Prince Frederick, MD
Posts: 9
Default Re: P0884 '03 Cruiser

Sorry fpr the delay in getting to you all. I know that people will hop on a forum, ask their question, the community helps them out, and you never hear from them again, I am not that kind of person. Moving on....
Dropped the Cruiser off on Tuesday night, dealer called me on Wednesday and said it was the converter. They even said it was covered by an emissions warranty that I knew nothing about.
They should have it up and running either today or tomorrow depending on when the new converter gets dropped off to them.
I will re-post with a breakdown if you all wish and if this fixes the cruiser. Thanks again guys.
Reply With Quote
  #6 (permalink)  
Old 23 Jul 2009, 01:47 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: P0884 '03 Cruiser

Thanks for getting back.
First time I heard of a converter failure - Sharkstooth was right on....
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #7 (permalink)  
Old 23 Jul 2009, 02:30 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: P0884 '03 Cruiser

Yep, had it on my Corvette. The Vette has dual headers but goes into one single CAT and back out to a "Y" pipe and then to 2 mufflers. The CAT broke up, pieces came out the back of the CAT and got clogged at the "Y" junction of the pipe. No top end. Would drive nice in the city but as soon as I tried to get going at higher speeds, it would sputter, not die but wouldn't let me go any faster.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 23 Jul 2009, 03:40 pm
Regular Cruiser
 
Join Date: Jul 2009
Location: Lake-O-The-Pines , E.Texas
Posts: 199
Default Re: P0884 '03 Cruiser

My Ex highway patrol fox mustang plugged up the cats on a regular basis..I changed them to a aftermarket free flow and have had no more problems
__________________
This Black Thing Keeps Chasing Me



YES ! That is a Ron Paul for President Sticker..

Growing OLD is Natural - Growing UP is Optional It's NEVER too late to have a Happy Childhood

Ed Sidders , Lake-O The-Pines , Northeast Texas
Reply With Quote
  #9 (permalink)  
Old 23 Jul 2009, 03:50 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: P0884 '03 Cruiser

To finish my story, I unhooked the "Y" pipe, shock out all the pieces of the gutted CAT, put it back together and even with a 7/8 empty CAT I passed the Maryland smog emissions test. Shows that the test is just a money making scheme and almost anything can get past the test.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #10 (permalink)  
Old 27 Jul 2009, 11:50 am
Fresh Cruiser
 
Join Date: Jul 2009
Location: Prince Frederick, MD
Posts: 9
Default Re: P0884 '03 Cruiser

Yep it was the CAT. They (dealership) topped of the trans fluid, they said it was low. Gave me a brief lecture to not use the NAPA gasket that came in the transmission filter kit box. Apparently it could let air in and cause the solenoid pack not to engage. I guess after they dropped the pan and resealed it with RTV, they topped it off. They installed a shiny new CAT for no charge. The grand total for the work $0. Chug a Bug is running just fine now. And some people say dealerships are evil...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 PT Street Cruiser Announced skylight PT Cruiser News and Rumors 3 23 Sep 2013 07:37 pm
2004 Chrysler PT Dream Cruiser Series 3 skylight PT Cruiser News and Rumors 10 18 Jun 2009 08:57 am
Exterior Mod List slayerdarkcross Exterior Accessories Forum 8 22 Jul 2008 03:54 pm
2006 PT Street Cruiser Route 66 Edition skylight PT Cruiser News and Rumors 35 17 Nov 2007 02:39 pm
New 2005 Convertible PT Dream Cruiser skylight PT Cruiser News and Rumors 4 11 Jan 2005 06:12 pm


All times are GMT -5. The time now is 10:00 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors