PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Please Help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Oct 2009, 09:33 am
Fresh Cruiser
 
Join Date: Oct 2009
Posts: 2
Default Please Help

I have a 2007 Pt cruiser at about 45k miles. recently the gas gauge has dropped all the service and warning lights (gas, air bag, battery, ect) have come on and then the gauge rises back to normal and the lights goes back off. Anyone have suggestions about what this is?
Reply With Quote
  #2 (permalink)  
Old 07 Oct 2009, 09:38 am
Cool Cruiser
 
Join Date: Jan 2009
Location: Augusta, GA
Posts: 234
Default Re: Please Help

First, disconnect the negative battery cable for about 15 minutes - this will reset everything. If the problem continues, I'd start looking for a loose connection under the dash, especially a common ground.
__________________
2005 Limited Turbo-Lite, auto in Cool Vanilla
Reply With Quote
  #3 (permalink)  
Old 07 Oct 2009, 09:48 am
Regular Cruiser
 
Join Date: Mar 2009
Posts: 140
Default Re: Please Help

You may need a new fuel level sending unit.

And one less thread on this subject......

car stalled

Reply With Quote
Reply

Tags
gauges, service lights


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:28 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors