PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Electrical issue?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 16 Oct 2009, 07:58 am
Fresh Cruiser
 
Join Date: Aug 2009
Posts: 19
Default Electrical issue?

So I had a strange occurrence while driving to work this morning.

It was a rainy day and as I was driving all of a sudden all the lights on my dash came on (much like when you first startup the car) and then they went away. This didn't affect my driving at all, headlights stayed on, etc.

It was just really strange that those lights all came on then went away.

I thought maybe the rain had something to do with it, but it was a light rain and I didn't drive through any big puddles, but the road was wet.

Any thoughts?
Reply With Quote
  #2 (permalink)  
Old 16 Oct 2009, 12:57 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Electrical issue?

Might be your multi-function switch starting to go bad. It has the dial on the stalk for the instrument lights.
You have fog lights?
Keep an eye out for them going on by themselves...
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 16 Oct 2009, 01:02 pm
Fresh Cruiser
 
Join Date: Aug 2009
Posts: 19
Default Re: Electrical issue?

Thanks for replying. I am not talking about the back light for the instrument cluster, I am talking about every warning light coming on, then they went off, then the alarm light came on and went off. It's essentially the same check that happens when I start my car, but this happened while I was driving.

Strange!
Reply With Quote
  #4 (permalink)  
Old 16 Oct 2009, 03:30 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Electrical issue?

Oh, that is strange. Did the car "cough"? I'm thinking maybe ignition switch lost contact?
Reply With Quote
  #5 (permalink)  
Old 16 Oct 2009, 08:28 pm
Fresh Cruiser
 
Join Date: Mar 2007
Location: Sarnia, ON, Canada.
Posts: 20
Default Re: Electrical issue?

I just had the same problem today on my 06 PTC- exactly the same. Only the warning lights came on. It did it twice when I drove home today. No hiccups and the engine ran fine, but something is wrong.

I cleaned the battery posts (they were somewhat corroded). I also removed the instrument cluster and examined the circuit board, but I couldn't detect anything out of the ordinary (nothing burnt).

HELP!!!!
__________________
2006 PT Cruiser MTX Base
Magnesium Pearl
100,000km/60,000mi
Reply With Quote
  #6 (permalink)  
Old 18 Oct 2009, 02:31 pm
Matt42's Avatar
Cool Cruiser
 
Join Date: Jun 2009
Location: Glendale, AZ
Posts: 499
Default Re: Electrical issue?

As Joe did, the first thing I would check would be the battery terminals. next, I would check where the various ground cables (black wires from the battery) fasten to the body and engine block. Intermittent ground problems can cause all sorts of electrical gremlins.
__________________
1996 Dodge diesel 4X4, 2001 PT Cruiser Touring with rear disc brakes, [Now gone 2004 PT Cruiser Base 5 speed], 2007 Chrysler T&C Touring
Reply With Quote
  #7 (permalink)  
Old 19 Oct 2009, 08:06 pm
Fresh Cruiser
 
Join Date: Mar 2007
Location: Sarnia, ON, Canada.
Posts: 20
Default Re: Electrical issue?

Thanks Matt - I'll have to trace all the ground wires coming off the battery and see what they look like at the ends. The battery terminals/connectors are clean now as is the main ground coming off the battery going to the body. I actually sanded away the paint on the body, then re-attached the ground.

So far,the problem hasn't come back, but that doesn't really mean anything, since I really haven't found a root cause.
__________________
2006 PT Cruiser MTX Base
Magnesium Pearl
100,000km/60,000mi
Reply With Quote
  #8 (permalink)  
Old 22 Oct 2009, 03:38 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Putnam County, Florida
Posts: 4
Unhappy Re: Electrical issue?

My 06 started having the same problem. All the lights on the panel go on and needles (gas, mph, tac) go down. Amost instantly the lights go off and needles return to normal. This has happened 10-15 times in the past 2 months. Twice the engine turned off for a split second then gained power agian.

I dont have fog lights. I checked the condition of the batt cables. They are very, very clean. I will check grounds and other wires.

I was at AutoZone to purchase part for another vehicle and had them pull codes on the Cruiser. No codes.

Anyway... its not a great feeling that the engine may cut off at anytime.

If anyone has fixed a similar problem I would like that informaiton.

Any help would be appricated.
Reply With Quote
  #9 (permalink)  
Old 22 Oct 2009, 05:53 pm
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Electrical issue?

You have a lot of weight on your keychain? (extra keys, etc.)
My hunch is ignition switch.
Reply With Quote
  #10 (permalink)  
Old 22 Oct 2009, 07:09 pm
Fresh Cruiser
 
Join Date: Jul 2009
Location: Putnam County, Florida
Posts: 4
Default Re: Electrical issue?

I had the same thought... yes there is more weight on my keychain than my wifes and the issue does not often occur when she is driving.

You have any idea of a fix or replace cost?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Gremlins SantaGuy General PT Cruiser Discussions 10 24 Sep 2009 05:01 am
need electrical help thundercat2 Tech & Performance Forum 0 27 Sep 2008 08:02 am
Electrical problems need help bad! SilverPT Tech & Performance Forum 2 14 Sep 2008 09:54 pm
Electrical Nightmare igloo0001 Tech & Performance Forum 10 08 Mar 2008 10:00 pm
Electrical problem ARAMIS327 PT Cruiser Convertible Forum 1 20 Nov 2007 07:47 pm


All times are GMT -5. The time now is 08:26 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors