PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
2006 TURN SIGNAL PROBLEM

 
Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #21 (permalink)  
Old 18 May 2015, 09:29 am
Samson's Avatar
Regular Cruiser
 
Join Date: Jan 2008
Location: Winchester, CA
Posts: 144
Default Re: 2006 TURN SIGNAL PROBLEM

Quote:
Originally Posted by ptcruisersteve View Post
What error do you get?
I can't remember the code, it was 3 years ago and I sold the car. 100% sure about the fix
Reply With Quote
  #22 (permalink)  
Old 18 May 2015, 01:08 pm
Fresh Cruiser
 
Join Date: Apr 2014
Location: Northern Indiana
Posts: 22
Default Re: 2006 TURN SIGNAL PROBLEM

Have you tried replacing the flasher relay? Remove the cover around the steering column it is mounted on the multi switch assembly little square relay they can be going bad, they are cheap to try .
Reply With Quote
  #23 (permalink)  
Old 18 May 2015, 01:45 pm
Samson's Avatar
Regular Cruiser
 
Join Date: Jan 2008
Location: Winchester, CA
Posts: 144
Default Re: 2006 TURN SIGNAL PROBLEM

Quote:
Originally Posted by aubert1541 View Post
Have you tried replacing the flasher relay? Remove the cover around the steering column it is mounted on the multi switch assembly little square relay they can be going bad, they are cheap to try .
100% gurantee you it isn't the flasher relay, ask me how I know. After replacing the offending bulb the computer needs a manufacturer specific clear/reset
Reply With Quote
  #24 (permalink)  
Old 18 May 2015, 02:04 pm
LionPT's Avatar
Veteran Cruiser
 
Join Date: May 2014
Location: Central Florida
Posts: 4,254
Default Re: 2006 TURN SIGNAL PROBLEM

Quote:
Originally Posted by aubert1541 View Post
Have you tried replacing the flasher relay? Remove the cover around the steering column it is mounted on the multi switch assembly little square relay they can be going bad, they are cheap to try .
G2's 2006-2010 have no flasher relay.
Ray_Dockrey likes this.
__________________

2006 Touring Edition in Cool Vanilla...aka/Ghost
Reply With Quote
  #25 (permalink)  
Old 23 May 2015, 03:20 am
Silverlicious's Avatar
Fresh Cruiser
 
Join Date: Aug 2012
Location: Eindhoven - The Netherlands
Posts: 3
Default Re: 2006 TURN SIGNAL PROBLEM

My problem is SOLVED !!!
Every bulb has a "return" wire which in my case is black.
One way or the other the return wire of the blinker was disconnected.
So i cut that wire from the harness and connected it to another black wire from the head light.
And YES... the blinkers are working fine again.

Perhaps this will also work for others.
Just measure the black connection wires.
__________________
Reply With Quote
  #26 (permalink)  
Old 23 May 2015, 10:19 am
Obsessed Cruiser
 
Join Date: Aug 2014
Location: Thousand Oaks, CA
Posts: 7,144
Default Re: 2006 TURN SIGNAL PROBLEM

Quote:
Originally Posted by Silverlicious View Post
Hello, my name is John.
Is there already a solution for this problem? I have exactly the same with my PT 2006 left front turning light.
Also changed the sides, bulb is OK. Tried every possible known reset option without result.
Thanks in advance.
Quote:
Originally Posted by Silverlicious View Post
My problem is SOLVED !!!
Every bulb has a "return" wire which in my case is black.
One way or the other the return wire of the blinker was disconnected.
So i cut that wire from the harness and connected it to another black wire from the head light.
And YES... the blinkers are working fine again.

Perhaps this will also work for others.
Just measure the black connection wires.
Do you know where that black return wire goes to from the blinker so others don't have to look it up in the wiring diagram?
Reply With Quote
  #27 (permalink)  
Old 24 May 2015, 12:52 pm
Silverlicious's Avatar
Fresh Cruiser
 
Join Date: Aug 2012
Location: Eindhoven - The Netherlands
Posts: 3
Default Re: 2006 TURN SIGNAL PROBLEM

Sorry, I don't know where that black return wire goes to.
I guess to the TIMP but in my opinion it is not that important.
Important is that all blinkers work fine now.
__________________
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 turn signal problem ricksterw General PT Cruiser Discussions 7 18 Feb 2010 05:59 pm
Rear turn signal problem leroy420 General PT Cruiser Discussions 5 18 Feb 2009 09:43 pm
Turn Signal Fuse Problem Indynick General PT Cruiser Discussions 1 04 Jul 2004 07:33 pm
blue turn signal bulbs that turn orange when in us Capt Kidd General PT Cruiser Discussions 1 04 Jun 2004 10:10 pm
Turn signal gonzomania Exterior Accessories Forum 12 30 Mar 2004 08:53 am


All times are GMT -5. The time now is 06:56 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors