PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Turn Signal Problem 2007 Pt

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 22 Jun 2010, 09:11 am
Fresh Cruiser
 
Join Date: Aug 2008
Posts: 3
Default Turn Signal Problem 2007 Pt

Help Please,

I have a 2007 PT, yesterday put on my right turn signal ,flashing fast, check
right front signal working ok, check rear signal no flashing, replace bulb still nothing , switch sockets between left on right ,still nothing. put on emergency flashers ,all light flashing except right rear.

Any Ideas
Thanks
Reply With Quote
  #2 (permalink)  
Old 22 Jun 2010, 10:26 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Turn Signal Problem 2007 Pt

If it isn't bulb or socket, that leaves wiring - look for a break in the wire.
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
  #3 (permalink)  
Old 26 Sep 2012, 01:13 pm
Fresh Cruiser
 
Join Date: Jan 2011
Location: 32767
Posts: 2
Default Re: Turn Signal Problem 2007 Pt

Will this help any owners
Signal light not working correctly
Back to the last cool Florida weather I remover the front wheel, passenger side, on my 2006 PT Cruiser to change the signal light bulb.
Yes, this is ridicules however, Chrysler shipped the work down to Mexico, Mexico made American car?
To my horror I found that the wires were (it looked like squirrels ate the wire right at the base of the socket) chewed up.
I super glued and taped the wire ( only way left to hook it up).
I priced the socket assemble at auto parts stores only to find that 2006 was too new for them to carry.
Go to a junk yard!
I priced the assembly at my Chrysler dealer, $188.00!
They also told me to go to a junk yard!
Today, because the signal light started acting funny while the headlights were on and the car computer also started acting funny, I remover the driver side wheel to change out that signal light bulb, I found that the wires to the socket were chew off in about the same place as the passenger side.
After a closer look, this time with my glasses on, I found out that this was not a squirrel hungry job but poor engineering on the part of Chrysler and their Mexico company!
The rubber cover, to protect the lights and wires from rain, was in fact rubbing on the wiring at the end of the socket and after a time it chewed through the wiring!
$.50 worth of wire connectors, lots of electrical tape and two new light bulbs $6.00 ( all of that work I just replaced both bulb).
Reply With Quote
  #4 (permalink)  
Old 26 Sep 2012, 01:20 pm
Veteran Cruiser
 
Join Date: Mar 2012
Location: darien il
Posts: 4,592
Default Re: Turn Signal Problem 2007 Pt

^WHAT?

Last edited by rob342; 26 Sep 2012 at 01:24 pm.
Reply With Quote
  #5 (permalink)  
Old 26 Sep 2012, 02:46 pm
Ray_Dockrey's Avatar
Senior Cruiser
 
Join Date: May 2012
Location: Mustang, OK
Posts: 1,213
Default Re: Turn Signal Problem 2007 Pt

It could also be a TIPM issue. But I would check the wiring as suggested above before going down that path.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 TURN SIGNAL PROBLEM dj78nc General PT Cruiser Discussions 26 24 May 2015 12:52 pm
2005 turn signal problem ricksterw General PT Cruiser Discussions 7 18 Feb 2010 05:59 pm
Rear turn signal problem leroy420 General PT Cruiser Discussions 5 18 Feb 2009 09:43 pm
Turn Signal Fuse Problem Indynick General PT Cruiser Discussions 1 04 Jul 2004 07:33 pm
blue turn signal bulbs that turn orange when in us Capt Kidd General PT Cruiser Discussions 1 04 Jun 2004 10:10 pm


All times are GMT -5. The time now is 11:55 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors