PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Finally Have A/C!

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 23 Jun 2010, 10:00 pm
Young Cruiser
 
Join Date: Mar 2010
Location: N.E. Ohio
Posts: 81
Default Finally Have A/C!

I bought this car in March and the previous owner just had the timing belt/waterpump done and the person who did the job disconnected the a/c lines per the service manual and apparently to save money didn't refill the system.

I've had enought not being able to drive my PT on hot days, so I dug into it today. I had to replace 2 o-rings here



...and replace the valve core on the low side. I did this at about noon today and at 7:30pm the last time I drove it the system was still fully charged and working excellent! Only time will tell if it actually holds the charge.

I'm surprised to drive it and find that having the a/c on doesn't effect driveability like I've seen posted on here. It actually drives better than my turbo Jetta with the a/c on. Total cost = 2 cans of r134a from big lots $10, 1 can of oil charge $5, and an assortedment of refrigerant grade o-rings from O'reileys $5
Reply With Quote
  #2 (permalink)  
Old 24 Jun 2010, 09:26 am
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,839
Default Re: Finally Have A/C!

Good fix. I really gave my AC a good test on fathers day it was 93 and I was stuck in traffic bumper to bumper and I was happy she didn't move off her regular spot on the temp gauge.
__________________



"the people should not fear their government, the government should fear the people"- Thomas Jefferson
Reply With Quote
  #3 (permalink)  
Old 24 Jun 2010, 08:50 pm
Young Cruiser
 
Join Date: Mar 2010
Location: N.E. Ohio
Posts: 81
Default Re: Finally Have A/C!

Quote:
Originally Posted by Dino View Post
Good fix. I really gave my AC a good test on fathers day it was 93 and I was stuck in traffic bumper to bumper and I was happy she didn't move off her regular spot on the temp gauge.
I hear that on the high temps outside. It was 90 here while I was fixing it and I let it run for a good 1/2 hour to make sure it wasn't going to overheat. I've seen quite a few posts on hear about the multi speed fan not working correctly and the engine overheating. One time today it went a hair above the half way point and then dropped right back down. It was fine the rest of the day.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Well Finally KingKole02 General PT Cruiser Discussions 2 29 Mar 2006 01:05 pm
Finally got a pic of my PT up jmack General PT Cruiser Discussions 5 03 Jan 2005 04:41 pm
Finally it's here ! turbomangt Vendors & Buyers Forum 2 21 Apr 2003 09:28 am
Finally... PhantumPTCruiser General PT Cruiser Discussions 8 28 Jan 2003 01:21 pm


All times are GMT -5. The time now is 07:18 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors