PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Please help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07 Jul 2010, 05:17 pm
Fresh Cruiser
 
Join Date: Nov 2008
Location: GTA, Ontario, Canada
Posts: 39
Send a message via MSN to saldagus
Unhappy Please help

Well last Friday I thoght I had a Harley idlng behind me. Turns out it was me.

Car idles real rough and lumpy, when I "blip" the throttle the engine raises rpms normally, however on the way down they drop to below 500 rpms, the engine stumbles, wants to die but recovers into it's lumpy idle.

Car idles fine when I first start it in the morning, but as soon as it gets slightly warm it starts missing.

I've changed plugs, wires, coil pack, intake manifold gaskets, checked for vacuum leaks, and cleaned the IAC. The kicker is no check engine light and no codes stored in memory.

Any suggestions besides attaching it to the end of a long chain and usig it as a boat anchor?
Reply With Quote
  #2 (permalink)  
Old 07 Jul 2010, 06:18 pm
ROCKETMAN8060's Avatar
Senior Cruiser
 
Join Date: Jan 2010
Location: Orlando FL
Posts: 1,753
Default Re: Please help

Quote:
Originally Posted by saldagus View Post
Well last Friday I thoght I had a Harley idlng behind me. Turns out it was me.

Car idles real rough and lumpy, when I "blip" the throttle the engine raises rpms normally, however on the way down they drop to below 500 rpms, the engine stumbles, wants to die but recovers into it's lumpy idle.

Car idles fine when I first start it in the morning, but as soon as it gets slightly warm it starts missing.

I've changed plugs, wires, coil pack, intake manifold gaskets, checked for vacuum leaks, and cleaned the IAC. The kicker is no check engine light and no codes stored in memory.

Any suggestions besides attaching it to the end of a long chain and usig it as a boat anchor?
What type of PT you have and how many miles it has?
__________________
ROCKETMAN8060
Reply With Quote
  #3 (permalink)  
Old 07 Jul 2010, 06:39 pm
Fresh Cruiser
 
Join Date: Nov 2008
Location: GTA, Ontario, Canada
Posts: 39
Send a message via MSN to saldagus
Default Re: Please help

It's an 01 na. With 225000 kms. Approx 140000 miles

rad fan has also been replaced
Reply With Quote
  #4 (permalink)  
Old 07 Jul 2010, 07:15 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Please help

Ya gotta ask the other things with that kind of mileage. Timing belt, water pump changed? Besides cleaning the IAC which control idle, did you check to make sure the spring is working correctly? Did you take a look inside the throttle body, it could probably use a good seafoam or major cleaning.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 07 Jul 2010, 07:41 pm
Fresh Cruiser
 
Join Date: Nov 2008
Location: GTA, Ontario, Canada
Posts: 39
Send a message via MSN to saldagus
Default Re: Please help

Timing belt and water pump were both done for the second time last year. Just did a seafoam treatment. What should I be looking for in the IAC?
Reply With Quote
  #6 (permalink)  
Old 07 Jul 2010, 08:03 pm
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,839
Default Re: Please help

Lower intake gasket??? Spray some starter fluid around it and see if it idles better.
__________________



"the people should not fear their government, the government should fear the people"- Thomas Jefferson
Reply With Quote
  #7 (permalink)  
Old 07 Jul 2010, 09:19 pm
Fresh Cruiser
 
Join Date: Nov 2008
Location: GTA, Ontario, Canada
Posts: 39
Send a message via MSN to saldagus
Default Re: Please help

Quote:
Originally Posted by Dino View Post
Lower intake gasket??? Spray some starter fluid around it and see if it idles better.
Did that with wd40. Also replaced the seals
Reply With Quote
  #8 (permalink)  
Old 08 Jul 2010, 07:51 am
Dino's Avatar
Senior Cruiser
 
Join Date: Feb 2010
Location: NY
Posts: 1,839
Default Re: Please help

Quote:
Originally Posted by saldagus View Post
Did that with wd40. Also replaced the seals
Sorry didn't see that, wow you do have a weird one. Fuel issue??
__________________



"the people should not fear their government, the government should fear the people"- Thomas Jefferson
Reply With Quote
  #9 (permalink)  
Old 08 Jul 2010, 08:08 am
quicksilverdon's Avatar
Obsessed Cruiser
 
Join Date: Nov 2003
Location: Felton, Delaware
Posts: 20,501
Default Re: Please help

I don't see anything about injectors - I've read of a couple intances where an injector was replaced and cured rough idle - try a lot of injector cleaner first.
Perhaps a compression test?
__________________
"Anti-intellectualism has been a constant thread winding its way through our political and cultural life,
nurtured by the false notion that democracy means that 'my ignorance is just as good as your knowledge."
Isaac Asimov"

'05 Limited Turbo Lite, (Silver, of course)4-wheel ABS, Sunroof, Spoiler. Mods: E&G Classic grill, K&N FIPK, BTG duals, rear lowered 1.5", LED washer lights, $20 catch can, Aoogah horn, Weatherflectors, Sunroof Deflector, Fuzzy Dice, rear logo flames, rear pinstripe graphic, Gen3 Taillights, rear sway bar, hood struts, Strut bar.
Traded in '02 Silver Touring Edition w/87,000 miles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:55 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors