PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Shot starter?

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 20 Aug 2010, 02:41 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 8
Default Shot starter?

Hello, I have a 2007 Cruiser non-turbo with 62,000 miles on it. It been running fine untill this morning I tried starting it and all Im hearing is a clicking from the starter. I replaced the battery and still the car wont turn over and all the starter does is clicks. There is some corrosion on the cables where they hook to the car. I cleaned them up pretty well but still the starter just clicks. I seem to have plenty of power to the rest of the car, the lights shine bright and the car powers up fine. Does this sound like my starter is shot? Ive tried searching and cant find much. Thanks.
Reply With Quote
  #2 (permalink)  
Old 20 Aug 2010, 02:52 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 8
Default Re: Shot starter?

Also my Wife work out of this car its constantly being started throughout the day. If I had to guess I would say she drives to 15-20 different places throughout the day. Thats alot of starting and wear on that little starter. Just thought Id add that.
Reply With Quote
  #3 (permalink)  
Old 20 Aug 2010, 03:39 pm
Fanatic Cruiser
 
Join Date: Mar 2010
Location: Billings, MT
Posts: 745
Default Re: Shot starter?

It's probably your starter contacts, especially if the starter is worked that much every day.
__________________
-Chris
2010 PT Cruiser Classic, Deep Water Blue
Reply With Quote
  #4 (permalink)  
Old 20 Aug 2010, 07:14 pm
Fresh Cruiser
 
Join Date: Apr 2008
Posts: 8
Default Re: Shot starter?

Fixed it. Turns out the cable that runs from the battery to the starter was REALLY corroded. Replaced that and now it starts. Thanks.
Reply With Quote
  #5 (permalink)  
Old 20 Aug 2010, 07:26 pm
EssexExport's Avatar
Cool Cruiser
 
Join Date: Mar 2009
Location: Rahway, NJ
Posts: 209
Default Re: Shot starter?

Sounds familiar. Happened to me, but it was a battery.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
This is a long shot... TexasPriest Exterior Accessories Forum 7 20 Jun 2008 11:34 pm
75HP Nitrous Shot on Turbo?? nitrouspt Turbo Performance 3 24 May 2005 08:36 pm
worth a shot JaxPT Classifieds: For Sale/Trade 8 26 Jan 2004 09:10 pm
100 hp shot on a Stage 1 GT? AA PT Stage Turbo Kits 39 08 Jan 2004 09:52 am


All times are GMT -5. The time now is 06:27 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors