PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Engine light

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02 Sep 2010, 06:02 am
ejstith's Avatar
Regular Cruiser
 
Join Date: Aug 2009
Location: Tallahassee, FL
Posts: 102
Default Engine light

Well after almost a year without a problem with my PT I have a strange situation. Wife stopped at the store the other day and when she got ready to go PT wouldn't start. Turned over but no start. After a bit it started but ran bad at every stop light. It was sort of like it was in "limp mode". She got it home & parked it. I was out of town but when I got back I started it up. I took it around the hood and although it didn't run perfect it did run pretty good but a little shaky at idle. I have an OBII reader hooked up all of the time and when I hooked it to my PC it showed nothing! I cleared the light and put it back in the car and cranked it back up. The check engine light blinked a couple of times and was on steady again. Repeated process and again nothing on my PC regarding the trouble code but the light is still on. This is the first time I've ever had a check engine light and the code reader didn't say what it was. Any ideas?
__________________
2005 PT, Limited turbo Lite. Automatic all whistles and bells.
Reply With Quote
  #2 (permalink)  
Old 02 Sep 2010, 06:30 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Engine light

Take the negative battery cable off for about 10 minutes. You'd be surprised how that fixes a lot of problems.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 02 Sep 2010, 09:21 am
ejstith's Avatar
Regular Cruiser
 
Join Date: Aug 2009
Location: Tallahassee, FL
Posts: 102
Default Re: Engine light

Thanks Cruzin, I'll try that .. Sure won't hurt anything ..
__________________
2005 PT, Limited turbo Lite. Automatic all whistles and bells.
Reply With Quote
  #4 (permalink)  
Old 02 Sep 2010, 01:04 pm
ejstith's Avatar
Regular Cruiser
 
Join Date: Aug 2009
Location: Tallahassee, FL
Posts: 102
Default Re: Engine light

Boy Cruwzin, there for a minute I thought you were an absolute genius! I took that cable off for about a half hour and put it back on. NO LIGHT! I went for a spin and it ran like a fine Swiss watch. I stopped a couple of places with no incident. I was convinced it was a fixed deal. THEN .... I stopped for gas and when I got ready to go I didn't think it was going to start and the engine light was on again. It finally started and as I was coming home it really ran funny. It would not go over 2500 RPM. It would jump & buck and carry on like a buckin' bronco. As long as it was not jumpin' and buckin' it ran fine just going down the road until ya mashed on the gas, even slightly. So .... back to the drawin' board. I just don't know why it doesn't show up on my OBII reader? But thanks anyway, you was a genius for a little bit ... LOL
__________________
2005 PT, Limited turbo Lite. Automatic all whistles and bells.
Reply With Quote
  #5 (permalink)  
Old 02 Sep 2010, 01:10 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Engine light

Ahhhhh, felt good there for a minute.

With the new engine light on, did you try your scanner again to see if there were any codes. If you can't go above 2500 RPM's then the computer put you in LIMP MODE. It does that so you can get home (slowly) and not hurt anything till you find the problem and fix it.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 02 Sep 2010, 02:34 pm
ejstith's Avatar
Regular Cruiser
 
Join Date: Aug 2009
Location: Tallahassee, FL
Posts: 102
Default Re: Engine light

Yeah I cleared the scanner and plugged it in with it screwing up. Still no code. I called Discount Auto Parts and they have a scanner. I don't know if theirs will show anything or not. I can imagine what Chrysler will charge me to fix this. Funny, the cooler it gets the higher it will rev. It's down to about half normal now and will rev (in neutral) to over 3 grand then goes to poppin' and bangin'. It backfires coming back down too... Something just isn't right here, ya know? Thanks Crewzin ..
__________________
2005 PT, Limited turbo Lite. Automatic all whistles and bells.
Reply With Quote
  #7 (permalink)  
Old 02 Sep 2010, 02:50 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Engine light

It's not supposed to rev any higher than that in neutral. The computer shuts down the injectors so you can't over rev it. It's a built-in safety feature.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #8 (permalink)  
Old 02 Sep 2010, 04:02 pm
Cool Cruiser
 
Join Date: Nov 2007
Posts: 394
Default Re: Engine light

Wondering why you didn't use the "built-in to the PT cruiser" engine trouble read out feature? Look up "key dance" you don't need a code reader.
Reply With Quote
  #9 (permalink)  
Old 03 Sep 2010, 08:37 pm
ejstith's Avatar
Regular Cruiser
 
Join Date: Aug 2009
Location: Tallahassee, FL
Posts: 102
Question Re: Engine light

Well Bob, I did that. The code is 0016 and the list I got off of this forum doesn't go that low. I also got an 0339 which relates to "slow response bank 1(?) but that may be because of 0016? I don't have a clue.
__________________
2005 PT, Limited turbo Lite. Automatic all whistles and bells.
Reply With Quote
  #10 (permalink)  
Old 03 Sep 2010, 08:43 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Engine light

Try this for your P0016 code:

code p0016

Error Code P0016?
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Engine misfire and flashing check engine light fg1911a1 General Turbo Discussions 15 26 Jul 2014 06:20 pm
Engine Light came on! BlueWoody General PT Cruiser Discussions 8 28 Jan 2010 03:59 am
Car Sometimes won't start (oil pressure light & Engine Light) gerardio Tech & Performance Forum 6 18 Jul 2008 08:22 am
Engine Light On...Big $ bados General Turbo Discussions 23 12 Jun 2008 04:28 pm
Engine Light On PT-Dave Turbo Performance 3 29 Jun 2003 06:04 pm


All times are GMT -5. The time now is 01:34 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors