PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Multifunction switch problem...or something else??

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11 Sep 2010, 02:37 pm
Young Cruiser
 
Join Date: Aug 2010
Location: Dallas, TX
Posts: 50
Default Multifunction switch problem...or something else??

This morning my mother-in-law goes out to get the newspaper, and finds the hazard lights flashing on her Cruiser. So she gets the key fob and presses the lock button, and they go off.

She tells me about it and asks if I might know what's wrong. I have no idea, but I'm afraid the lights may have been flashing for quite some time, so I try to start the car to see if the battery is dead. It is.

My first thought is the multifunction switch is toast. But all the accounts I've read about bad MF switches have to do with the fog lights coming on, not the hazards. So is it possible/likely that my problem is the MF switch, or could it be something else?
Reply With Quote
  #2 (permalink)  
Old 11 Sep 2010, 03:50 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Multifunction switch problem...or something else??

Would your mother-in-law know the difference and say she saw the hazard lights and it was the headlights and turn signal lights and tail lights flashing? Could the alarm had gone off (although the horn is supposed to sound also) and you didn't hear the horn?

If all that isn't possible, yea, you probably have a problem with the MFS.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 11 Sep 2010, 04:25 pm
Young Cruiser
 
Join Date: Aug 2010
Location: Dallas, TX
Posts: 50
Default Re: Multifunction switch problem...or something else??

Hey Crewzin, thanks for your reply...I knew I could count on you!

My Mother-in-law was very clear in describing the signal lights as flashing on-off-on-off. She didn't mention headlights or fog lights, and I didn't think to ask that specifically.

I asked her if she had maybe accidentally pressed the button on the key fob as she went out to get the paper, but she said she didn't have the keys with her, and had to go back inside the house to get them. She unlocked/locked the car via the fob, and the lights stopped flashing.

When I came over to look at the car, of course nothing was flashing. I thought maybe the alarm had been tripped as well, but she said the horn did not sound. I pressed the panic button on the fob to see if the car would behave as expected, and it did; the lights flashed and horn sounded once per second continually. I will ask if she remembers the head/fog lights coming on also.

In the meantime, I called my local Dodge dealer, and they quoted $159 for the MF switch...ouch! I've read on this Forum that others have paid half that much, though that was a year or two ago. I guess I will shop around a bit and see if I can do better.
Reply With Quote
  #4 (permalink)  
Old 11 Sep 2010, 04:35 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Multifunction switch problem...or something else??

$80 from Rock Auto.com with fog lights (but not in stock right now). But keep searching around. eBay might have some cheaper.

2001 CHRYSLER PT CRUISER Multi-Function Switch
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #5 (permalink)  
Old 11 Sep 2010, 06:41 pm
Young Cruiser
 
Join Date: Aug 2010
Location: Dallas, TX
Posts: 50
Default Re: Multifunction switch problem...or something else??

Okay, mother-in-law just called me...it's doing it again, only this time lights and horn are going off...so sounds like the alarm was set off. So maybe not the MF switch after all? What might cause the alarm to go off intermittently?
Reply With Quote
  #6 (permalink)  
Old 11 Sep 2010, 06:51 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Multifunction switch problem...or something else??

Low battery dropping voltage or a bad door or hood (2001 and 2002 only) sensor. The tailgate and the ignition switch will also trigger the alarm.

I'm not sure of the testing procedures to find out what's wrong. Unfortunately the No#10 fuse will disable the alarm but it also controls exterior lighting, remote keyless entry and door locks.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #7 (permalink)  
Old 11 Sep 2010, 08:00 pm
Young Cruiser
 
Join Date: Aug 2010
Location: Dallas, TX
Posts: 50
Default Re: Multifunction switch problem...or something else??

Just got back from M-I-L's place. First thing I noticed when I got there is that the hood latch was released...looks like somebody failed to close the hood properly. This, I am guessing, is the cause of the problem.

Anyway, the battery was dead, so I boosted it and drove it home for observation overnight. Now that the hood is positively latched and closed, I don't expect any more troubles.

Crewzin, thanks for your help with this. Have a great evening!
Reply With Quote
  #8 (permalink)  
Old 11 Sep 2010, 08:19 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Multifunction switch problem...or something else??

No problem. Hope that was the cause of the alarm going off. 01 and 02 are the only one's with that hood alarm sensor. Chrysler did away with it as a cost savings measure in the other years.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multifunction switch gonzomania General PT Cruiser Discussions 20 07 Apr 2015 07:08 pm
MultiFunction Switch Issues-HELP !!! jmack General PT Cruiser Discussions 10 26 Mar 2012 01:58 am
I need a multifunction switch w/ fog cowboyinboxers Classifieds: For Sale/Trade 1 01 Jun 2010 04:56 pm
Multifunction switch jaball0 Tech & Performance Forum 1 03 Aug 2007 08:03 pm
Multifunction switch gonzomania General PT Cruiser Discussions 5 23 Feb 2004 05:35 pm


All times are GMT -5. The time now is 11:12 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors