PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Found bad Torque strut when replacing LCA's

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 14 Sep 2010, 11:51 am
Fresh Cruiser
 
Join Date: Aug 2010
Posts: 10
Default Found bad Torque strut when replacing LCA's

I needed new ball joints and bushings so I did the whole Lower Control arm on both sides of my 2001 PT LE. While I had the lower torque strut out, I noticed that the rubber was split. I ordered a new one. I might not have noticed but I was cleaning it and saw that one of the rubber spokes was split right in the middle.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What is the torque strut adjustment procedure? ChampageCruiser Feedback and Support 0 03 Sep 2010 12:21 am
New LCA's and still have a clunk... Jetta02awp Wheels, Tires, Suspension 0 24 Jul 2010 07:13 pm
Strut rod nut torque Espresso Wheels, Tires, Suspension 2 08 Jun 2005 04:08 pm
Upper Torque Strut Installed Mean Green Turbo Performance 1 24 Jan 2005 12:03 pm
Strut bolts torque spec's? silky Wheels, Tires, Suspension 4 21 Jan 2004 11:17 pm


All times are GMT -5. The time now is 06:26 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors