PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Help...replaced heator core but seens to have new problems...

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 19 Sep 2010, 01:54 am
Fresh Cruiser
 
Join Date: Sep 2010
Location: Vancouver, Canada
Posts: 13
Default Help...replaced heator core but seens to have new problems...

Was hoping someone could help me with this. Just replaced my heator core but now there is a constant smell coming into the car interior. They also flushed the rad, replaced some hoses and two belts(alternator and ac belts)
Today went for a drive and got caught in some real slow traffic and the temp gauge went right up before the red. I kept the heater on and would turn off the engine. This seemed to work. Everything was fine when the car was moving and it seemed to correct itself after sitting for awhile. (I think the fan did turn on) Could this be a faulty thermostat.(which I replaced)
Also now my rear window wipers and its dash, lite are not working. I know they would have had to take the dash off to replace the heater core, could something not have been reconnected to cause the wipers and its lite to stop working. I would appreciate any answers or suggestions. Even so I am prepared before I go back to the shop.
Reply With Quote
  #2 (permalink)  
Old 19 Sep 2010, 05:35 am
chigger_ns's Avatar
Cool Cruiser
 
Join Date: May 2010
Posts: 278
Default Re: Help...replaced heator core but seens to have new problems...

A plug not properly connected or a blown fuse. Could be a pinched wire... take it back!!
__________________
2001 PT 5 speed Touring Edition
Eibach Pro Springs, Energy Suspension HyperFlex Master Kit bushings, 17" RTX Euro wheels, K&N drop in air filter, MotoMaster flat plate AGM battery, KYB GR2 shocks and struts, Booger standard shifter bushings, Ooogah horn.
Reply With Quote
  #3 (permalink)  
Old 19 Sep 2010, 06:32 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Help...replaced heator core but seens to have new problems...

chigger is correct in thinking the shop probably missed a connection in the dash for the electrics. As far as overheating, why did you think the fan turned on? If the high speed did come n, it's very loud, you can't miss the sound. If you didn't hear that then it probably didn't come on. Also, hopefully, they bled the coolant system of any excess air when they filled it back up.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 19 Sep 2010, 08:51 pm
Fresh Cruiser
 
Join Date: Sep 2010
Location: Vancouver, Canada
Posts: 13
Default Re: Help...replaced heator core but seens to have new problems...

Thanks for the reply. The fan is definitly working and the temp gauge is staying in the middle now. But the smell is still there which is concerning.
I'll take it back to the shop and see if they will agree on the wiper missed connection. Since it is behind the dash they are not going to be too happy.
I just always dread going into a shop unprepared as to what they are going to say. I worry they just see $$$ so thanks again for the input.
Reply With Quote
  #5 (permalink)  
Old 20 Sep 2010, 02:28 pm
Fresh Cruiser
 
Join Date: Sep 2010
Location: Vancouver, Canada
Posts: 13
Default Re: Help...replaced heator core but seens to have new problems...

Sorry have more questions about my heater core replacement. Took the car back to the mechanic because it is still smelling. He says it is going to smell like this for a couple of weeks! Honestly can't drive the car with window up.
He also says that the temp gauge going to the red has nothing to do with the work he did. He flushed the rad and replaced the cap. Also says the rear wiper connection could not have been effected when they took off the dash to replace the heater core. Again would appreciate any advise on this.

I started a new thread by mistake
Reply With Quote
  #6 (permalink)  
Old 20 Sep 2010, 02:46 pm
Fanatic Cruiser
 
Join Date: Mar 2010
Location: Billings, MT
Posts: 745
Default Re: Help...replaced heator core but seens to have new problems...

I tend to agree with what the mechanic said with the exception of the overheating. He worked on the cooling system, and now the car overheats. That makes it his problem. He at least owes you a diagnosis to prove that it's not related to the work he did.

You're going to have a coolant smell remain in the car after a heater core replacement while there is still residual coolant in the heater box. The smell will eventually go away.

Do you have a pre-2006? If so, the connection could very well have to do with him removing the dash. Maybe he just didn't plug the switch back in. He needs to pull the switch out and check the wires.

Go back and talk to his manager.
__________________
-Chris
2010 PT Cruiser Classic, Deep Water Blue
Reply With Quote
  #7 (permalink)  
Old 21 Sep 2010, 04:45 am
chigger_ns's Avatar
Cool Cruiser
 
Join Date: May 2010
Posts: 278
Default Re: Help...replaced heator core but seens to have new problems...

Check if you have power at the rear wiper with the switch on. If not, it could be a faulty switch, or a blown fuse.

as for the over head...I would say the mechanic didn't burp the cooling system properly and had an air pocket. I think it should be ok because it stopped overheating but check your coolant level again.
__________________
2001 PT 5 speed Touring Edition
Eibach Pro Springs, Energy Suspension HyperFlex Master Kit bushings, 17" RTX Euro wheels, K&N drop in air filter, MotoMaster flat plate AGM battery, KYB GR2 shocks and struts, Booger standard shifter bushings, Ooogah horn.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater core and rad replacement ddash General PT Cruiser Discussions 4 14 Sep 2010 06:35 pm
WTB: Turbo core or turbine wheel reklaweelmada Classifieds: Want To Buy 0 13 Oct 2009 10:14 am
Waterpump replaced, now problems. ptguy Tech & Performance Forum 4 07 Sep 2007 05:12 pm
looking for hard core performance guy in AZ tthrift Turbo Performance 5 22 Jan 2004 11:59 pm
anyone have the Core MBC?? magictrickboy71 Turbo Performance 3 20 Jun 2003 10:58 am


All times are GMT -5. The time now is 11:41 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors