PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Rad fan not working after work was done on vehicle

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 25 Sep 2010, 12:43 pm
Fresh Cruiser
 
Join Date: Sep 2010
Location: Vancouver, Canada
Posts: 13
Default Rad fan not working after work was done on vehicle

Ok, I just replaced heater core. Had issues of nearly over heating the next day, took it back to mechanic they said now it needs a new fan. "Crewzing" has been very helpful. (You were right they forgot to do connections for the wipers and such when they put back the dash) Any suggestions if this could be a fuse, relay?, or should I just replace the fan. Hoping to do it myself, mechanice quoted $7-800 and a parts place said they could get me a fan in a week for about $180. (Even girls need to save $)
Also the temp seems to be staying at half way except if I let it idle for over five minutes at a time. Is it ok to drive it short distances till I figure it out.
Thanks for the patience.
Reply With Quote
  #2 (permalink)  
Old 25 Sep 2010, 12:51 pm
Hooligan's Avatar
Obsessed Cruiser
 
Join Date: Aug 2003
Posts: 6,023
Default Re: Rad fan not working after work was done on vehicle

ddash, I see you are from Canada but fans here in the states run $70-$90. There is a VERY good "sticky" in the performance section on how to change it out. I personally have never done it so I can't tell you if it is easy or not. Mainly removing grille and pieces to get back to the fan.
__________________

2008 Silver Steel Metallic, Touring, NA, Sirius; Chromed door handles; lower grille; fog light surrounds; chrome front & rear bumpers strips; Airaid air filter; Bassani duals; Modesty Cover; Autolite AP5263 Platinum Plugs (.040); Crane Plug Wires; NAPA Ceramic pads; Blane hood struts; PTeazer Gas, Brake & Foot Rest Pedals, '05 Rear Step Pad, Stainless Door Sills, Llumar tint, "A" Piller chrome; APC Strut Bar
Reply With Quote
  #3 (permalink)  
Old 25 Sep 2010, 04:04 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Rad fan not working after work was done on vehicle

Like Hooligan, search around and see if you can find a fan for a lot less than $180. Is there an eBay for Canada? Not sure. There's one for England where all the parts are in sterling.

Have you done mechanical work before? Do yo a decent set of tools? If you want to try it yourself, here's the link.

Removing the fan and housing 01-05 PT

As far as using the car, just keep an eye on the temperature guage. If it starts to raise above half way shut it down.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #4 (permalink)  
Old 26 Sep 2010, 08:39 pm
Fresh Cruiser
 
Join Date: Sep 2010
Location: Vancouver, Canada
Posts: 13
Default Re: Rad fan not working after work was done on vehicle

Thanks for the link Crewzin. I am going to look around for a less expensive fan. We do have ebay so I will look at that too. I have done a little mc work and I change my oil, filters,switches etc myself.Nothing like brakes but I am willing to always try to attempt to do it myself ,lol, you could say I try to fix things vs replace things house & car. Most times I am successful sometimes not so much. I do have the basic tools and it looks like all you really need is a good rachhet and small hands. My grill appears to be a bit different than yours to move the rad to get the fan out but your pictures really help. So please wish me luck and any other advice is always appreciated
Reply With Quote
  #5 (permalink)  
Old 26 Sep 2010, 08:59 pm
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Rad fan not working after work was done on vehicle

Make sure the fan is for your year car. Take your time, look at the fan and you can see the bolts and electrical connection that will have to work with. Give yourself plenty of time, don't rush anything. Good luck. If there's questions, come back here and somebody will try and help.
__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #6 (permalink)  
Old 29 Sep 2010, 05:29 pm
Fresh Cruiser
 
Join Date: Sep 2010
Location: Vancouver, Canada
Posts: 13
Cool Re: Rad fan not working after work was done on vehicle

Just wanted to do a big THANK YOU for the advice,support and links with pictures. Much better than my Haynes manual. I just finished replacing the radiator fan. I managed to find one in a parts store in town for $150 (they gave me the "perfered rate". I know it is cheaper in the States or on line but I got it right away and I still saved so much by doing it myself.
The job was easy, I just took Crewzin advice and didn't rush it. The hardest part was getting the bolts in and out because everything is so tight. I have small hands, how do guys with big hands do it This is now in my favorites on my computer and I definitely will be returning on a regular bases. Thanks again Crewzin and Hooligan. Your
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PT Vehicle Wrap she_so Exterior Accessories Forum 4 26 Jun 2009 01:30 pm
what other vehicle rims will fit the gt? Punch Wheels, Tires, Suspension 9 23 Oct 2003 02:02 pm
Most Beautiful Vehicle 2sb General PT Cruiser Discussions 29 31 Jan 2003 10:20 am
What category of vehicle is a PT? 2coolPT General PT Cruiser Discussions 1 08 Jul 2002 12:44 am


All times are GMT -5. The time now is 03:26 pm.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors