PT Cruiser Forum  
Advertisements
       

Go Back   PT Cruiser Forum > General Forums > General PT Cruiser Discussions

PT Cruiser Forum

Advertisements
Horn problem! Need help

 
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10 Oct 2010, 09:10 pm
Fresh Cruiser
 
Join Date: Oct 2010
Posts: 3
Default Horn problem! Need help

The horn is unplugged due to it wont stop blowing. What would cause the horn to stay on?

2004 with 47K miles

Joe
Reply With Quote
  #2 (permalink)  
Old 11 Oct 2010, 04:45 am
Obsessed Cruiser
 
Join Date: Sep 2001
Posts: 27,744
Default Re: Horn problem! Need help

A problem at the steering wheel connection?

__________________
Rules of the forum have been updated as of *07/07/2019* Please read them over.

- All decisions by the Moderator are semi-permanent, can and may be changed at his discretion but definitely will be the final word. Any action performed by the Administrator or Moderators are not to be discussed on the forum.
Reply With Quote
  #3 (permalink)  
Old 12 Oct 2010, 09:51 pm
Fresh Cruiser
 
Join Date: Oct 2010
Posts: 3
Default Re: Horn problem! Need help

Thanks!
Reply With Quote
  #4 (permalink)  
Old 13 Oct 2010, 05:18 am
Young Cruiser
 
Join Date: Aug 2010
Location: Dallas, TX
Posts: 50
Default Re: Horn problem! Need help

Have you had the steering wheel off?

I had this problem with my '67 Belvedere after I replaced the steering wheel. Turned out I had pinched one of the horn wires when tightening the new wheel down thereby grounding out the switch.
Reply With Quote
  #5 (permalink)  
Old 17 Oct 2010, 09:25 pm
Fresh Cruiser
 
Join Date: Oct 2010
Posts: 3
Default Re: Horn problem! Need help

Thanks. There has been some work done. Could be the problem.

Joe
Reply With Quote
  #6 (permalink)  
Old 17 Oct 2010, 11:05 pm
Freezinghot's Avatar
Fanatic Cruiser
 
Join Date: Jun 2010
Location: Fort Worth, Tx
Posts: 547
Default Re: Horn problem! Need help

Did it happen after you used it?
Here in the road range capital of the US , if you honk your horn at someone , expect to get followed home.
__________________
04 graphite(vroom!) N/A Limited 110,000 miles -original owner. Custom short ram intake ( CGS motor-sport pipe, specter open-end air filter, specter breathing hose),OEM spoiler, Pioneer receiver ,10" bazooka sub,Blue LED interior lighting, Bosch +4 plugs and Accel super stock 8mm universal plug wires.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn button problem??? vetteloverpa General PT Cruiser Discussions 20 24 Sep 2014 03:27 pm
Horn/Radio Problem Madturtle Tech & Performance Forum 5 03 Dec 2012 08:38 pm
Wierd Horn Problem digitalpinscruiser Tech & Performance Forum 3 07 Jun 2008 06:23 am
Horn and headlights problem ducerman Tech & Performance Forum 6 18 Dec 2007 10:24 pm
Problem with Horn Button vetteloverpa Tech & Performance Forum 6 18 Feb 2006 06:40 pm


All times are GMT -5. The time now is 07:28 am.




Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.
vB.Sponsors